[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <cover.1621665058.git.christophe.jaillet@wanadoo.fr>
Date: Sat, 22 May 2021 08:52:35 +0200
From: Christophe JAILLET <christophe.jaillet@...adoo.fr>
To: arnd@...db.de, gregkh@...uxfoundation.org,
mihai.carabas@...cle.com, andriy.shevchenko@...ux.intel.com,
pizhenwei@...edance.com, pbonzini@...hat.com,
bobo.shaobowang@...wei.com, linqiheng@...wei.com
Cc: linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org,
Christophe JAILLET <christophe.jaillet@...adoo.fr>
Subject: [PATCH v2 0/5] misc/pvpanic: Fix some errro handling path and simplify code
This serie was previously sent in 2 parts, one for -pci.c and one for
-mmio.c.
Execpt the patch 5/5 which is new, the 4 first patches are the same as the
ones previously posted. Only the description has been slighly updated.
Pacth 5/5 is a proposal to simplify code and turn 'pvpanic_probe()' into a
fully resource managed version.
This way callers don't need to do some clean-up on error in the
probe and on remove.
"Reviewed-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>" was only
added on patch 1 and 3. I was unsure if his Reviewed-by was also related to
the s/GFP_ATOMIC/GFP_KERNEL/ of patch 2 et 4.
Christophe JAILLET (5):
misc/pvpanic-pci: Fix error handling in 'pvpanic_pci_probe()'
misc/pvpanic-pci: Use GFP_KERNEL instead of GFP_ATOMIC
misc/pvpanic-mmio: Fix error handling in 'pvpanic_mmio_probe()'
misc/pvpanic-mmio: Use GFP_KERNEL instead of GFP_ATOMIC
misc/pvpanic: Make 'pvpanic_probe()' resource managed
drivers/misc/pvpanic/pvpanic-mmio.c | 17 ++--------------
drivers/misc/pvpanic/pvpanic-pci.c | 22 ++++-----------------
drivers/misc/pvpanic/pvpanic.c | 30 ++++++++++++++---------------
drivers/misc/pvpanic/pvpanic.h | 3 +--
4 files changed, 22 insertions(+), 50 deletions(-)
--
2.30.2
Powered by blists - more mailing lists