[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <56cdb86fe8984a94b4a7a8073476d849@AcuMS.aculab.com>
Date: Mon, 24 May 2021 16:34:39 +0000
From: David Laight <David.Laight@...LAB.COM>
To: 'Mark Rutland' <mark.rutland@....com>,
Christoph Hellwig <hch@...radead.org>
CC: Joe Richey <joerichey94@...il.com>,
"trivial@...nel.org" <trivial@...nel.org>,
Joe Richey <joerichey@...gle.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
"x86@...nel.org" <x86@...nel.org>,
"H. Peter Anvin" <hpa@...or.com>,
Paolo Bonzini <pbonzini@...hat.com>,
Lorenzo Pieralisi <lorenzo.pieralisi@....com>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Zhangfei Gao <zhangfei.gao@...aro.org>,
Zhou Wang <wangzhou1@...ilicon.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"kvm@...r.kernel.org" <kvm@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
"linux-media@...r.kernel.org" <linux-media@...r.kernel.org>,
"linux-accelerators@...ts.ozlabs.org"
<linux-accelerators@...ts.ozlabs.org>
Subject: RE: [PATCH 0/6] Don't use BIT() macro in UAPI headers
From: Mark Rutland
> Sent: 24 May 2021 13:29
>
> On Mon, May 24, 2021 at 12:46:26PM +0100, Christoph Hellwig wrote:
> > On Thu, May 20, 2021 at 03:43:37AM -0700, Joe Richey wrote:
> > > This patch series changes all UAPI uses of BIT() to just be open-coded.
> > > However, there really should be a check for this in checkpatch.pl
> > > Currently, the script actually _encourages_ users to use the BIT macro
> > > even if adding things to UAPI.
> >
> > Yes. In fact it should warn about BIT() in general. It is totally
> > pointless obsfucation that doesn't even save any typing at all.
>
> That's not quite true; the point is that if you use BIT() consistently,
> then even when you refer to bits 32 to 63 you won't accidentally
> introduce shifts of more than the width of int, and the definition will
> work equally well for assembly and C, which isn't true if you use `1UL`
> in the definition.
>
> With that in mind it's shorter and clearer than its functional
> equivalent:
>
> BIT(x)
> (UL(1) << (x))
>
> So IMO it's preferable to use BIT() generally, or _BITUL() in uapi
> headers.
And then, suddenly the compiler warns about truncation of the
high bits when ~BIT(x) is used to mask a 32bit value on 64bit systems.
Once the C standard committee had decided to change from K&R's
'sign preserving' integer promotions to 'value preserving'
you always lose somewhere.
Personally I prefer hex constants - I can't count bits at all.
David
-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
Powered by blists - more mailing lists