[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1621930520-515336-2-git-send-email-wubo40@huawei.com>
Date: Tue, 25 May 2021 16:15:19 +0800
From: Wu Bo <wubo40@...wei.com>
To: <viro@...iv.linux.org.uk>, <herbert@...dor.apana.org.au>,
<davem@...emloft.net>, <linux-fsdevel@...r.kernel.org>,
<linux-crypto@...r.kernel.org>, <linux-kernel@...r.kernel.org>
CC: <linfeilong@...wei.com>, <wubo40@...wei.com>
Subject: [PATCH 1/2] crypto: af_alg - use DIV_ROUND_UP helper macro for calculations
From: Wu Bo <wubo40@...wei.com>
Replace open coded divisor calculations with the DIV_ROUND_UP kernel
macro for better readability.
Signed-off-by: Wu Bo <wubo40@...wei.com>
---
crypto/af_alg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/crypto/af_alg.c b/crypto/af_alg.c
index 18cc82d..8bd288d 100644
--- a/crypto/af_alg.c
+++ b/crypto/af_alg.c
@@ -411,7 +411,7 @@ int af_alg_make_sg(struct af_alg_sgl *sgl, struct iov_iter *iter, int len)
if (n < 0)
return n;
- npages = (off + n + PAGE_SIZE - 1) >> PAGE_SHIFT;
+ npages = DIV_ROUND_UP(off + n, PAGE_SIZE);
if (WARN_ON(npages == 0))
return -EINVAL;
/* Add one extra for linking */
--
1.8.3.1
Powered by blists - more mailing lists