lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <871r9stpd5.wl-maz@kernel.org>
Date:   Thu, 27 May 2021 11:58:30 +0100
From:   Marc Zyngier <maz@...nel.org>
To:     Valentin Schneider <valentin.schneider@....com>
Cc:     linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
        Thomas Gleixner <tglx@...utronix.de>,
        Lorenzo Pieralisi <lorenzo.pieralisi@....com>,
        Vincenzo Frascino <vincenzo.frascino@....com>
Subject: Re: [RFC PATCH v2 02/10] genirq: Define irq_ack() and irq_eoi() helpers

On Thu, 27 May 2021 11:55:50 +0100,
Marc Zyngier <maz@...nel.org> wrote:
> 
> On Tue, 25 May 2021 18:32:47 +0100,
> Valentin Schneider <valentin.schneider@....com> wrote:
> > 
> > The newly-added IRQCHIP_AUTOMASKS_FLOW flag requires some additional
> > bookkeeping around chip->{irq_ack, irq_eoi}() calls. Define wrappers around
> > those chip callbacks to drive the IRQD_IRQ_FLOW_MASKED state of an IRQ when
> > the chip has the IRQCHIP_AUTOMASKS_FLOW flag.
> > 
> > Signed-off-by: Valentin Schneider <valentin.schneider@....com>
> > ---
> >  kernel/irq/chip.c      | 16 ++++++++++++++++
> >  kernel/irq/internals.h |  2 ++
> >  2 files changed, 18 insertions(+)
> > 
> > diff --git a/kernel/irq/chip.c b/kernel/irq/chip.c
> > index 21a21baa1366..793dbd8307b9 100644
> > --- a/kernel/irq/chip.c
> > +++ b/kernel/irq/chip.c
> > @@ -408,6 +408,22 @@ void irq_percpu_disable(struct irq_desc *desc, unsigned int cpu)
> >  	cpumask_clear_cpu(cpu, desc->percpu_enabled);
> >  }
> >  
> > +void ack_irq(struct irq_desc *desc)
> > +{
> > +	desc->irq_data.chip->irq_ack(&desc->irq_data);
> > +
> > +	if (desc->irq_data.chip->flags & IRQCHIP_AUTOMASKS_FLOW)
> > +		irq_state_set_flow_masked(desc);
> > +}
> > +
> > +void eoi_irq(struct irq_desc *desc)
> > +{
> > +	desc->irq_data.chip->irq_eoi(&desc->irq_data);
> > +
> > +	if (desc->irq_data.chip->flags & IRQCHIP_AUTOMASKS_FLOW)
> > +		irq_state_clr_flow_masked(desc);
> > +}
> > +
> >  static inline void mask_ack_irq(struct irq_desc *desc)
> >  {
> >  	if (desc->irq_data.chip->irq_mask_ack) {
> > diff --git a/kernel/irq/internals.h b/kernel/irq/internals.h
> > index b6c1cceddec0..090bd7868845 100644
> > --- a/kernel/irq/internals.h
> > +++ b/kernel/irq/internals.h
> > @@ -87,6 +87,8 @@ extern void irq_enable(struct irq_desc *desc);
> >  extern void irq_disable(struct irq_desc *desc);
> >  extern void irq_percpu_enable(struct irq_desc *desc, unsigned int cpu);
> >  extern void irq_percpu_disable(struct irq_desc *desc, unsigned int cpu);
> > +extern void irq_ack(struct irq_desc *desc);
> > +extern void irq_eoi(struct irq_desc *desc);
> 
> Nit: we have {un,}mask_irq, but you add irq_{ack,eoi}. It'd be good to
> have some naming consistency (yes, this may/will clash with existing
> code, but we can fix that as well).

Actually, the helpers do have the right naming, but the internal
declarations are the ones that are wrong...

	M.

-- 
Without deviation from the norm, progress is not possible.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ