[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <11235207-1b76-fbfd-316e-a4f6f885d928@intel.com>
Date: Thu, 27 May 2021 13:16:02 +0200
From: Cezary Rojewski <cezary.rojewski@...el.com>
To: YueHaibing <yuehaibing@...wei.com>,
pierre-louis.bossart@...ux.intel.com,
liam.r.girdwood@...ux.intel.com, yang.jie@...ux.intel.com,
broonie@...nel.org, perex@...ex.cz, tiwai@...e.com
Cc: alsa-devel@...a-project.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro
On 2021-05-24 1:55 PM, YueHaibing wrote:
> Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
>
> Signed-off-by: YueHaibing <yuehaibing@...wei.com>
> ---
Thanks for your input.
Reviewed-by: Cezary Rojewski <cezary.rojewski@...el.com>
Regards,
Czarek
> sound/soc/intel/skylake/skl-nhlt.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/sound/soc/intel/skylake/skl-nhlt.c b/sound/soc/intel/skylake/skl-nhlt.c
> index 87c891c46291..64226072f0ee 100644
> --- a/sound/soc/intel/skylake/skl-nhlt.c
> +++ b/sound/soc/intel/skylake/skl-nhlt.c
> @@ -149,8 +149,8 @@ int skl_nhlt_update_topology_bin(struct skl_dev *skl)
> return 0;
> }
>
> -static ssize_t skl_nhlt_platform_id_show(struct device *dev,
> - struct device_attribute *attr, char *buf)
> +static ssize_t platform_id_show(struct device *dev,
> + struct device_attribute *attr, char *buf)
> {
> struct pci_dev *pci = to_pci_dev(dev);
> struct hdac_bus *bus = pci_get_drvdata(pci);
> @@ -166,7 +166,7 @@ static ssize_t skl_nhlt_platform_id_show(struct device *dev,
> return sprintf(buf, "%s\n", platform_id);
> }
>
> -static DEVICE_ATTR(platform_id, 0444, skl_nhlt_platform_id_show, NULL);
> +static DEVICE_ATTR_RO(platform_id);
>
> int skl_nhlt_create_sysfs(struct skl_dev *skl)
> {
>
Powered by blists - more mailing lists