[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e95b8c85-4878-eec7-f568-5f16f7fcf955@collabora.com>
Date: Fri, 28 May 2021 08:27:51 +0300
From: Dafna Hirschfeld <dafna.hirschfeld@...labora.com>
To: Irui Wang <irui.wang@...iatek.com>,
Alexandre Courbot <acourbot@...omium.org>,
Hans Verkuil <hverkuil-cisco@...all.nl>,
Tiffany Lin <tiffany.lin@...iatek.com>,
Andrew-CT Chen <andrew-ct.chen@...iatek.com>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Rob Herring <robh+dt@...nel.org>,
Matthias Brugger <matthias.bgg@...il.com>,
Tomasz Figa <tfiga@...gle.com>,
Hsin-Yi Wang <hsinyi@...omium.org>,
Maoguang Meng <maoguang.meng@...iatek.com>,
Longfei Wang <longfei.wang@...iatek.com>,
Yong Wu <yong.wu@...iatek.com>
Cc: Yunfei Dong <yunfei.dong@...iatek.com>,
Fritz Koenig <frkoenig@...omium.org>,
Tzung-Bi Shih <tzungbi@...omium.org>,
linux-media@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
srv_heupstream@...iatek.com, linux-mediatek@...ts.infradead.org,
Project_Global_Chrome_Upstream_Group@...iatek.com
Subject: Re: [PATCH v4,5/6] media: mtk-vcodec: Add MT8192 H264 venc driver
Hi
On 21.05.21 10:01, Irui Wang wrote:
> Add MT8192 venc driver's compatible and device private data.
>
> Signed-off-by: Irui Wang <irui.wang@...iatek.com>
> ---
> drivers/media/platform/mtk-vcodec/mtk_vcodec_drv.h | 1 +
> .../media/platform/mtk-vcodec/mtk_vcodec_enc_drv.c | 14 ++++++++++++++
> 2 files changed, 15 insertions(+)
>
> diff --git a/drivers/media/platform/mtk-vcodec/mtk_vcodec_drv.h b/drivers/media/platform/mtk-vcodec/mtk_vcodec_drv.h
> index d03cca95e99b..14893d277bb8 100644
> --- a/drivers/media/platform/mtk-vcodec/mtk_vcodec_drv.h
> +++ b/drivers/media/platform/mtk-vcodec/mtk_vcodec_drv.h
> @@ -302,6 +302,7 @@ struct mtk_vcodec_ctx {
> enum mtk_chip {
> MTK_MT8173,
> MTK_MT8183,
> + MTK_MT8192,
> };
>
> /**
> diff --git a/drivers/media/platform/mtk-vcodec/mtk_vcodec_enc_drv.c b/drivers/media/platform/mtk-vcodec/mtk_vcodec_enc_drv.c
> index 26b089e81213..78f3dd166917 100644
> --- a/drivers/media/platform/mtk-vcodec/mtk_vcodec_enc_drv.c
> +++ b/drivers/media/platform/mtk-vcodec/mtk_vcodec_enc_drv.c
> @@ -425,12 +425,26 @@ static const struct mtk_vcodec_enc_pdata mt8183_pdata = {
> .core_id = VENC_SYS,
> };
>
> +static const struct mtk_vcodec_enc_pdata mt8192_pdata = {
> + .chip = MTK_MT8192,
> + .uses_ext = true,
> + /* MT8192 supports the same capture formats as MT8183*/
missing space before '*/'
> + .capture_formats = mtk_video_formats_capture_mt8183,
> + .num_capture_formats = ARRAY_SIZE(mtk_video_formats_capture_mt8183),
> + /* MT8192 supports the same output formats as MT8173 */
> + .output_formats = mtk_video_formats_output_mt8173,
> + .num_output_formats = ARRAY_SIZE(mtk_video_formats_output_mt8173),
If all three models mt8173, mt8183 and mt8192 support the same formats then
we should probably not name the structs according to one of the models, so maybe:
s/mtk_video_formats_capture_mt8183/mtk_video_formats_capture/
s/mtk_video_formats_output_mt8173/mtk_video_formats_output/
or some other naming
Thanks,
Dafna
> + .min_bitrate = 64,
> + .max_bitrate = 100000000,
> + .core_id = VENC_SYS,
> +};
> static const struct of_device_id mtk_vcodec_enc_match[] = {
> {.compatible = "mediatek,mt8173-vcodec-enc",
> .data = &mt8173_avc_pdata},
> {.compatible = "mediatek,mt8173-vcodec-enc-vp8",
> .data = &mt8173_vp8_pdata},
> {.compatible = "mediatek,mt8183-vcodec-enc", .data = &mt8183_pdata},
> + {.compatible = "mediatek,mt8192-vcodec-enc", .data = &mt8192_pdata},
> {},
> };
> MODULE_DEVICE_TABLE(of, mtk_vcodec_enc_match);
>
Powered by blists - more mailing lists