lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Mon, 7 Jun 2021 16:25:38 +0200
From:   "Rafael J. Wysocki" <rafael@...nel.org>
To:     Zhen Lei <thunder.leizhen@...wei.com>
Cc:     "Rafael J . Wysocki" <rafael.j.wysocki@...el.com>,
        linux-acpi <linux-acpi@...r.kernel.org>,
        linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/1] PNP: use DEVICE_ATTR_RO macro

On Wed, Jun 2, 2021 at 10:15 AM Zhen Lei <thunder.leizhen@...wei.com> wrote:
>
> Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
> the code a bit shorter and easier to read.
>
> Signed-off-by: Zhen Lei <thunder.leizhen@...wei.com>
> ---
>  drivers/pnp/card.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/pnp/card.c b/drivers/pnp/card.c
> index 2430c14f472d26a..d40ed8621571b0a 100644
> --- a/drivers/pnp/card.c
> +++ b/drivers/pnp/card.c
> @@ -181,8 +181,8 @@ struct pnp_card *pnp_alloc_card(struct pnp_protocol *protocol, int id, char *pnp
>         return card;
>  }
>
> -static ssize_t pnp_show_card_name(struct device *dmdev,
> -                                 struct device_attribute *attr, char *buf)
> +static ssize_t name_show(struct device *dmdev,
> +                        struct device_attribute *attr, char *buf)
>  {
>         char *str = buf;
>         struct pnp_card *card = to_pnp_card(dmdev);
> @@ -191,10 +191,10 @@ static ssize_t pnp_show_card_name(struct device *dmdev,
>         return (str - buf);
>  }
>
> -static DEVICE_ATTR(name, S_IRUGO, pnp_show_card_name, NULL);
> +static DEVICE_ATTR_RO(name);
>
> -static ssize_t pnp_show_card_ids(struct device *dmdev,
> -                                struct device_attribute *attr, char *buf)
> +static ssize_t card_id_show(struct device *dmdev,
> +                           struct device_attribute *attr, char *buf)
>  {
>         char *str = buf;
>         struct pnp_card *card = to_pnp_card(dmdev);
> @@ -207,7 +207,7 @@ static ssize_t pnp_show_card_ids(struct device *dmdev,
>         return (str - buf);
>  }
>
> -static DEVICE_ATTR(card_id, S_IRUGO, pnp_show_card_ids, NULL);
> +static DEVICE_ATTR_RO(card_id);
>
>  static int pnp_interface_attach_card(struct pnp_card *card)
>  {
> --

Applied as 5.14 material, thanks!

Powered by blists - more mailing lists