lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 22 Jun 2021 12:07:53 +1000
From:   Alistair Popple <apopple@...dia.com>
To:     Peter Xu <peterx@...hat.com>
CC:     <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
        Andrea Arcangeli <aarcange@...hat.com>,
        "Kirill A . Shutemov" <kirill@...temov.name>,
        Axel Rasmussen <axelrasmussen@...gle.com>,
        Nadav Amit <nadav.amit@...il.com>,
        Hugh Dickins <hughd@...gle.com>,
        Jerome Glisse <jglisse@...hat.com>,
        Jason Gunthorpe <jgg@...pe.ca>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Miaohe Lin <linmiaohe@...wei.com>,
        Mike Rapoport <rppt@...ux.vnet.ibm.com>,
        Matthew Wilcox <willy@...radead.org>,
        Mike Kravetz <mike.kravetz@...cle.com>
Subject: Re: [PATCH v3 08/27] mm: Introduce zap_details.zap_flags

On Tuesday, 22 June 2021 2:16:50 AM AEST Peter Xu wrote:
> On Mon, Jun 21, 2021 at 10:09:00PM +1000, Alistair Popple wrote:
> > On Friday, 28 May 2021 6:21:30 AM AEST Peter Xu wrote:
> > > Instead of trying to introduce one variable for every new zap_details fields,
> > > let's introduce a flag so that it can start to encode true/false informations.
> > > 
> > > Let's start to use this flag first to clean up the only check_mapping variable.
> > > Firstly, the name "check_mapping" implies this is a "boolean", but actually it
> > > stores the mapping inside, just in a way that it won't be set if we don't want
> > > to check the mapping.
> > > 
> > > To make things clearer, introduce the 1st zap flag ZAP_FLAG_CHECK_MAPPING, so
> > > that we only check against the mapping if this bit set.  At the same time, we
> > > can rename check_mapping into zap_mapping and set it always.
> > > 
> > > Since at it, introduce another helper zap_check_mapping_skip() and use it in
> > > zap_pte_range() properly.
> > > 
> > > Some old comments have been removed in zap_pte_range() because they're
> > > duplicated, and since now we're with ZAP_FLAG_CHECK_MAPPING flag, it'll be very
> > > easy to grep this information by simply grepping the flag.
> > > 
> > > It'll also make life easier when we want to e.g. pass in zap_flags into the
> > > callers like unmap_mapping_pages() (instead of adding new booleans besides the
> > > even_cows parameter).
> > > 
> > > Signed-off-by: Peter Xu <peterx@...hat.com>
> > > ---
> > >  include/linux/mm.h | 19 ++++++++++++++++++-
> > >  mm/memory.c        | 31 ++++++++-----------------------
> > >  2 files changed, 26 insertions(+), 24 deletions(-)
> > > 
> > > diff --git a/include/linux/mm.h b/include/linux/mm.h
> > > index db155be8e66c..52d3ef2ed753 100644
> > > --- a/include/linux/mm.h
> > > +++ b/include/linux/mm.h
> > > @@ -1721,13 +1721,30 @@ static inline bool can_do_mlock(void) { return false; }
> > >  extern int user_shm_lock(size_t, struct user_struct *);
> > >  extern void user_shm_unlock(size_t, struct user_struct *);
> > >  
> > > +/* Whether to check page->mapping when zapping */
> > > +#define  ZAP_FLAG_CHECK_MAPPING             BIT(0)
> > > +
> > >  /*
> > >   * Parameter block passed down to zap_pte_range in exceptional cases.
> > >   */
> > >  struct zap_details {
> > > -	struct address_space *check_mapping;	/* Check page->mapping if set */
> > > +	struct address_space *zap_mapping;
> > > +	unsigned long zap_flags;
> > >  };
> > >  
> > > +/* Return true if skip zapping this page, false otherwise */
> > > +static inline bool
> > > +zap_check_mapping_skip(struct zap_details *details, struct page *page)
> > > +{
> > > +	if (!details || !page)
> > > +		return false;
> > > +
> > > +	if (!(details->zap_flags & ZAP_FLAG_CHECK_MAPPING))
> > > +		return false;
> 
> [1]
> 
> > > +
> > > +	return details->zap_mapping != page_rmapping(page);
> > 
> > I doubt this matters in practice, but there is a slight behaviour change
> > here that might be worth checking. Previously this check was equivalent
> > to:
> > 
> > details->zap_mapping && details->zap_mapping != page_rmapping(page)
> 
> Yes; IMHO "details->zap_mapping" is just replaced by the check at [1].

Yes, but what I meant is that this check is slightly different in behaviour
from the old code which would never skip if check/zap_mapping == NULL where as
the new code will skip if
details->zap_mapping == NULL && page_rmapping(page) != NULL because the check
has effectively become:

				if ((details->zap_flags & ZAP_FLAG_CHECK_MAPPING) &&
				    details->zap_mapping != page_rmapping(page))
					continue;

instead of:

				if (details->zap_mapping &&
				    details->zap_mapping != page_rmapping(page))
					continue;

As I said though I only looked at this superficially from the perspective of
whether this patch changes existing code behaviour. I doubt this is a real
problem because I assume
details->check_mapping == NULL && page_rmapping(page) != NULL can never
actually happen in practice.

> For example, there's only one real user of this mapping check, which is
> unmap_mapping_pages() below [2].
> 
> With the old code, we have:
> 
>     details.check_mapping = even_cows ? NULL : mapping;
> 
> So "details->zap_mapping" is only true if "!even_cows".
> 
> With the new code, we'll have:
> 
>     if (!even_cows)
>         details.zap_flags |= ZAP_FLAG_CHECK_MAPPING;
> 
> So ZAP_FLAG_CHECK_MAPPING is only set if "!even_cows", while that's what we
> check exactly at [1].
> > 
> > Otherwise I think this looks good.
> > 
> > > +}
> > > +
> > >  struct page *vm_normal_page(struct vm_area_struct *vma, unsigned long addr,
> > >  			     pte_t pte);
> > >  struct page *vm_normal_page_pmd(struct vm_area_struct *vma, unsigned long addr,
> > > diff --git a/mm/memory.c b/mm/memory.c
> > > index 27cf8a6375c6..c9dc4e9e05b5 100644
> > > --- a/mm/memory.c
> > > +++ b/mm/memory.c
> > > @@ -1330,16 +1330,8 @@ static unsigned long zap_pte_range(struct mmu_gather *tlb,
> > >  			struct page *page;
> > >  
> > >  			page = vm_normal_page(vma, addr, ptent);
> > > -			if (unlikely(details) && page) {
> > > -				/*
> > > -				 * unmap_shared_mapping_pages() wants to
> > > -				 * invalidate cache without truncating:
> > > -				 * unmap shared but keep private pages.
> > > -				 */
> > > -				if (details->check_mapping &&
> > > -				    details->check_mapping != page_rmapping(page))
> > > -					continue;
> > > -			}
> > > +			if (unlikely(zap_check_mapping_skip(details, page)))
> > > +				continue;
> > >  			ptent = ptep_get_and_clear_full(mm, addr, pte,
> > >  							tlb->fullmm);
> > >  			tlb_remove_tlb_entry(tlb, pte, addr);
> > > @@ -1372,17 +1364,8 @@ static unsigned long zap_pte_range(struct mmu_gather *tlb,
> > >  		    is_device_exclusive_entry(entry)) {
> > >  			struct page *page = pfn_swap_entry_to_page(entry);
> > >  
> > > -			if (unlikely(details && details->check_mapping)) {
> > > -				/*
> > > -				 * unmap_shared_mapping_pages() wants to
> > > -				 * invalidate cache without truncating:
> > > -				 * unmap shared but keep private pages.
> > > -				 */
> > > -				if (details->check_mapping !=
> > > -				    page_rmapping(page))
> > > -					continue;
> > > -			}
> > > -
> > > +			if (unlikely(zap_check_mapping_skip(details, page)))
> > > +				continue;
> > >  			pte_clear_not_present_full(mm, addr, pte, tlb->fullmm);
> > >  			rss[mm_counter(page)]--;
> > >  
> > > @@ -3345,9 +3328,11 @@ void unmap_mapping_pages(struct address_space *mapping, pgoff_t start,
> > >  		pgoff_t nr, bool even_cows)
> > >  {
> > >  	pgoff_t	first_index = start, last_index = start + nr - 1;
> > > -	struct zap_details details = { };
> > > +	struct zap_details details = { .zap_mapping = mapping };
> > > +
> > > +	if (!even_cows)
> > > +		details.zap_flags |= ZAP_FLAG_CHECK_MAPPING;
> > >  
> > > -	details.check_mapping = even_cows ? NULL : mapping;
> 
> [2]
> 
> > >  	if (last_index < first_index)
> > >  		last_index = ULONG_MAX;
> 
> Thanks,
> 
> 




Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ