[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e728719d-8e43-0e5a-af7a-14196dafa2a9@acm.org>
Date: Wed, 23 Jun 2021 13:59:16 -0700
From: Bart Van Assche <bvanassche@....org>
To: Can Guo <cang@...eaurora.org>, asutoshd@...eaurora.org,
nguyenb@...eaurora.org, hongwus@...eaurora.org,
ziqichen@...eaurora.org, linux-scsi@...r.kernel.org,
kernel-team@...roid.com
Cc: Alim Akhtar <alim.akhtar@...sung.com>,
Avri Altman <avri.altman@....com>,
"James E.J. Bottomley" <jejb@...ux.ibm.com>,
"Martin K. Petersen" <martin.petersen@...cle.com>,
Stanley Chu <stanley.chu@...iatek.com>,
Bean Huo <beanhuo@...ron.com>,
Jaegeuk Kim <jaegeuk@...nel.org>,
Adrian Hunter <adrian.hunter@...el.com>,
Satya Tangirala <satyat@...gle.com>,
Kiwoong Kim <kwmad.kim@...sung.com>,
open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v4 02/10] scsi: ufs: Add flags pm_op_in_progress and
is_sys_suspended
On 6/23/21 12:35 AM, Can Guo wrote:
> diff --git a/drivers/scsi/ufs/ufshcd.h b/drivers/scsi/ufs/ufshcd.h
> index 93aeeb3..1e7fe73 100644
> --- a/drivers/scsi/ufs/ufshcd.h
> +++ b/drivers/scsi/ufs/ufshcd.h
> @@ -754,6 +754,8 @@ struct ufs_hba {
> struct device_attribute spm_lvl_attr;
> /* A flag to tell whether __ufshcd_wl_suspend/resume() is in progress */
> bool wlu_pm_op_in_progress;
> + /* A flag to tell whether ufshcd_suspend/resume() is in progress */
> + bool pm_op_in_progress;
>
> /* Auto-Hibernate Idle Timer register value */
> u32 ahit;
> @@ -841,6 +843,8 @@ struct ufs_hba {
> struct ufs_clk_scaling clk_scaling;
> /* A flag to tell whether the UFS device W-LU is system suspended */
> bool is_wlu_sys_suspended;
> + /* A flag to tell whether hba is system suspended */
> + bool is_sys_suspended;
>
> enum bkops_status urgent_bkops_lvl;
> bool is_urgent_bkops_lvl_checked;
It is not yet clear to me whether we really need these new member
variables. If these are retained, please rename pm_op_in_progress into
platform_pm_op_in_progress and is_sys_suspended into
platform_is_sys_suspended.
Thanks,
Bart.
Powered by blists - more mailing lists