[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210701140328epcms1p85149318b6c18fa18b3c7c8e966c14db0@epcms1p8>
Date: Thu, 01 Jul 2021 23:03:28 +0900
From: 권오훈 <ohoono.kwon@...sung.com>
To: "robh+dt@...nel.org" <robh+dt@...nel.org>,
"frowand.list@...il.com" <frowand.list@...il.com>
CC: "lee.jones@...aro.org" <lee.jones@...aro.org>,
권오훈 <ohoono.kwon@...sung.com>,
"ohkwon1043@...il.com" <ohkwon1043@...il.com>,
"devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: [PATCH] of: base: remove unnecessary for loop
In __of_get_next_child function, loop iteration for getting next node is
unnecessary.
for loop is already checking if next is NULL or not, and
of_node_get(next) always returns next itself.
Therefore checking return value in the if clause always evaluates to
true, and thus it always breaks out from for loop in the first iteration.
Remove the unnecessary for loop for readability.
I tested the code as below, and it showed that BUG was never called.
- for (; next; next = next->sibling)
+ for (; next; next = next->sibling) {
if (of_node_get(next))
break;
+ BUG();
+ }
Signed-off-by: Ohhoon Kwon <ohoono.kwon@...sung.com>
---
drivers/of/base.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/of/base.c b/drivers/of/base.c
index 48e941f99558..ca60988ef428 100644
--- a/drivers/of/base.c
+++ b/drivers/of/base.c
@@ -708,9 +708,7 @@ static struct device_node *__of_get_next_child(const struct device_node *node,
return NULL;
next = prev ? prev->sibling : node->child;
- for (; next; next = next->sibling)
- if (of_node_get(next))
- break;
+ of_node_get(next);
of_node_put(prev);
return next;
}
--
2.17.1
Powered by blists - more mailing lists