[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YOvuw6oLGOSm8Yuj@dhcp22.suse.cz>
Date: Mon, 12 Jul 2021 09:26:59 +0200
From: Michal Hocko <mhocko@...e.com>
To: Miaohe Lin <linmiaohe@...wei.com>
Cc: akpm@...ux-foundation.org, hannes@...xchg.org, vbabka@...e.cz,
axboe@...nel.dk, iamjoonsoo.kim@....com, alexs@...nel.org,
apopple@...dia.com, willy@...radead.org, minchan@...nel.org,
david@...hat.com, shli@...com, hillf.zj@...baba-inc.com,
linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/5] mm/vmscan: add 'else' to remove check_pending label
On Sat 10-07-21 18:03:28, Miaohe Lin wrote:
> We could add 'else' to remove the somewhat odd check_pending label to
> make code core succinct.
Yes, this makes the code easier to follow. The two modes of throttling
depending on the fs reclaim mode is more obvious now.
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
Acked-by: Michal Hocko <mhocko@...e.com>
Thanks!
> ---
> mm/vmscan.c | 14 +++++---------
> 1 file changed, 5 insertions(+), 9 deletions(-)
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index c580bef6b885..a74760c48bd8 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -3428,18 +3428,14 @@ static bool throttle_direct_reclaim(gfp_t gfp_mask, struct zonelist *zonelist,
> * blocked waiting on the same lock. Instead, throttle for up to a
> * second before continuing.
> */
> - if (!(gfp_mask & __GFP_FS)) {
> + if (!(gfp_mask & __GFP_FS))
> wait_event_interruptible_timeout(pgdat->pfmemalloc_wait,
> allow_direct_reclaim(pgdat), HZ);
> + else
> + /* Throttle until kswapd wakes the process */
> + wait_event_killable(zone->zone_pgdat->pfmemalloc_wait,
> + allow_direct_reclaim(pgdat));
>
> - goto check_pending;
> - }
> -
> - /* Throttle until kswapd wakes the process */
> - wait_event_killable(zone->zone_pgdat->pfmemalloc_wait,
> - allow_direct_reclaim(pgdat));
> -
> -check_pending:
> if (fatal_signal_pending(current))
> return true;
>
> --
> 2.23.0
--
Michal Hocko
SUSE Labs
Powered by blists - more mailing lists