[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210714194645.GA1869525@bjorn-Precision-5520>
Date: Wed, 14 Jul 2021 14:46:45 -0500
From: Bjorn Helgaas <helgaas@...nel.org>
To: Boqun Feng <boqun.feng@...il.com>
Cc: Bjorn Helgaas <bhelgaas@...gle.com>, Arnd Bergmann <arnd@...db.de>,
Marc Zyngier <maz@...nel.org>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>,
"K. Y. Srinivasan" <kys@...rosoft.com>,
Haiyang Zhang <haiyangz@...rosoft.com>,
Stephen Hemminger <sthemmin@...rosoft.com>,
Wei Liu <wei.liu@...nel.org>, Dexuan Cui <decui@...rosoft.com>,
Lorenzo Pieralisi <lorenzo.pieralisi@....com>,
Rob Herring <robh@...nel.org>,
Krzysztof WilczyĆski <kw@...ux.com>,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-hyperv@...r.kernel.org, linux-pci@...r.kernel.org,
Sunil Muthuswamy <sunilmut@...rosoft.com>,
Mike Rapoport <rppt@...nel.org>
Subject: Re: [RFC v4 3/7] arm64: PCI: Support root bridge preparation for
Hyper-V PCI
On Wed, Jul 14, 2021 at 06:27:33PM +0800, Boqun Feng wrote:
> Currently at root bridge preparation, the corresponding ACPI device will
> be set as the companion, however for a Hyper-V virtual PCI root bridge,
> there is no corresponding ACPI device, because a Hyper-V virtual PCI
> root bridge is discovered via VMBus rather than ACPI table. In order to
> support this, we need to make pcibios_root_bridge_prepare() work with
> cfg->parent being NULL.
It would be nice to have a hint about why we don't actually need the
ACPI companion device in this case.
> Signed-off-by: Boqun Feng <boqun.feng@...il.com>
> ---
> arch/arm64/kernel/pci.c | 8 +++++++-
> 1 file changed, 7 insertions(+), 1 deletion(-)
>
> diff --git a/arch/arm64/kernel/pci.c b/arch/arm64/kernel/pci.c
> index 1006ed2d7c60..3b81ac42bc1f 100644
> --- a/arch/arm64/kernel/pci.c
> +++ b/arch/arm64/kernel/pci.c
> @@ -84,7 +84,13 @@ int pcibios_root_bridge_prepare(struct pci_host_bridge *bridge)
> {
> if (!acpi_disabled) {
> struct pci_config_window *cfg = bridge->bus->sysdata;
> - struct acpi_device *adev = to_acpi_device(cfg->parent);
> + /*
> + * On Hyper-V there is no corresponding APCI device for a root
> + * bridge, therefore ->parent is set as NULL by the driver. And
> + * set 'adev` as NULL in this case because there is no proper
> + * ACPI device.
> + */
> + struct acpi_device *adev = cfg->parent ? to_acpi_device(cfg->parent) : NULL;
> struct device *bus_dev = &bridge->bus->dev;
>
> ACPI_COMPANION_SET(&bridge->dev, adev);
s/APCI/ACPI/ above.
I think this would be more readable like this:
struct pci_config_window *cfg = bridge->bus->sysdata;
...
if (acpi_disabled)
return 0;
/*
* On Hyper-V there is no corresponding ACPI device for a root
* ...
*/
cfg = bridge->bus->sysdata;
if (!cfg->parent)
return 0;
adev = to_acpi_device(cfg->parent);
bus_dev = &bridge->bus->dev;
ACPI_COMPANION_SET(&bridge->dev, adev);
...
This could be done in two steps: the first to restructure the code
without making any functional change, and a second to return when
there's no cfg->parent. If you do it in one step, the patch will be
much harder to read.
Bjorn
Powered by blists - more mailing lists