[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210715045531.420201-3-mcgrof@kernel.org>
Date: Wed, 14 Jul 2021 21:55:27 -0700
From: Luis Chamberlain <mcgrof@...nel.org>
To: axboe@...nel.dk
Cc: hare@...e.de, bvanassche@....org, ming.lei@...hat.com,
hch@...radead.org, jack@...e.cz, osandov@...com,
linux-block@...r.kernel.org, linux-kernel@...r.kernel.org,
Luis Chamberlain <mcgrof@...nel.org>
Subject: [PATCH v2 2/6] block: move disk announce work from register_disk() to a helper
This moves quite a bit of code which does one thing into a helper.
We currently do not check for errors but we may decide that might
be desirable later.
This also makes the code easier to read.
This change has no functional changes.
Signed-off-by: Luis Chamberlain <mcgrof@...nel.org>
---
block/genhd.c | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/block/genhd.c b/block/genhd.c
index 4dd6db3618f2..520e23b25ed5 100644
--- a/block/genhd.c
+++ b/block/genhd.c
@@ -390,6 +390,15 @@ static void disk_scan_partitions(struct gendisk *disk)
blkdev_put(bdev, FMODE_READ);
}
+static void disk_announce(struct gendisk *disk)
+{
+ struct device *ddev = disk_to_dev(disk);
+
+ /* announce the disk and partitions after all partitions are created */
+ dev_set_uevent_suppress(ddev, 0);
+ disk_uevent(disk, KOBJ_ADD);
+}
+
static void register_disk(struct device *parent, struct gendisk *disk,
const struct attribute_group **groups)
{
@@ -433,10 +442,7 @@ static void register_disk(struct device *parent, struct gendisk *disk,
return;
disk_scan_partitions(disk);
-
- /* announce the disk and partitions after all partitions are created */
- dev_set_uevent_suppress(ddev, 0);
- disk_uevent(disk, KOBJ_ADD);
+ disk_announce(disk);
if (disk->queue->backing_dev_info->dev) {
err = sysfs_create_link(&ddev->kobj,
--
2.27.0
Powered by blists - more mailing lists