[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <a79b8c48-fd45-01c5-e43d-66077c495941@gmx.de>
Date: Thu, 15 Jul 2021 18:28:42 +0200
From: Helge Deller <deller@....de>
To: "Matthew Wilcox (Oracle)" <willy@...radead.org>,
linux-arch@...r.kernel.org, linux-parisc@...r.kernel.org,
linux-mips@...r.kernel.org, linux-arm-kernel@...ts.infradead.org
Cc: linux-kernel@...r.kernel.org
Subject: Re: [PATCH 0/3] Make PMD_ORDER generically available
On 7/15/21 3:46 PM, Matthew Wilcox (Oracle) wrote:
> These three architectures each define PMD_ORDER to mean "the order of
> an allocation for a PMD table", but logically PMD_ORDER should be the
> order of a PMD allocation, ie (PMD_SHIFT - PAGE_SHIFT) as DAX defines it.
Some architectures do have PGD_ORDER, PUD_ORDER and PTE_ORDER as well.
If you rename PMD_ORDER, IMHO the others should be renamed too.
Why not simply rename "PMD_ORDER" in fs/dax.c to e.g.
#define DAX_PMD_SHIFT (PMD_SHIFT - PAGE_SHIFT)
and use that inside the dax filesystem code?
Helge
> Could each architecture maintainer please apply the appropriate patch
> to their respective trees?
>
> Matthew Wilcox (Oracle) (3):
> arm: Rename PMD_ORDER to PMD_TABLE_ORDER
> mips: Rename PMD_ORDER to PMD_TABLE_ORDER
> parisc: Rename PMD_ORDER to PMD_TABLE_ORDER
>
> arch/arm/kernel/head.S | 34 +++++++++++++++---------------
> arch/mips/include/asm/pgalloc.h | 2 +-
> arch/mips/include/asm/pgtable-32.h | 2 +-
> arch/mips/include/asm/pgtable-64.h | 18 ++++++++--------
> arch/mips/kernel/asm-offsets.c | 2 +-
> arch/parisc/include/asm/pgalloc.h | 6 +++---
> arch/parisc/include/asm/pgtable.h | 4 ++--
> arch/parisc/mm/init.c | 4 ++--
> 8 files changed, 36 insertions(+), 36 deletions(-)
>
Powered by blists - more mailing lists