[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YPE9ZSu1lYtRb1DA@google.com>
Date: Fri, 16 Jul 2021 09:03:49 +0100
From: Lee Jones <lee.jones@...aro.org>
To: Fei Shao <fshao@...omium.org>
Cc: Gene Chen <gene_chen@...htek.com>,
Matthias Brugger <matthias.bgg@...il.com>,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-mediatek@...ts.infradead.org
Subject: Re: [PATCH 2/2] mfd: mt6360: Restore error message to regmap_read
failure
On Tue, 29 Jun 2021, Fei Shao wrote:
> This adds back a missing error message for better log readability.
>
> Fixes: e84702940613 ("mfd: mt6360: Fix flow which is used to check ic
> exist")
>
> Signed-off-by: Fei Shao <fshao@...omium.org>
> ---
>
> drivers/mfd/mt6360-core.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/mfd/mt6360-core.c b/drivers/mfd/mt6360-core.c
> index 6eaa6775b888..0ff8dae4536c 100644
> --- a/drivers/mfd/mt6360-core.c
> +++ b/drivers/mfd/mt6360-core.c
> @@ -351,8 +351,10 @@ static int mt6360_check_vendor_info(struct mt6360_ddata *ddata)
> int ret;
>
> ret = regmap_read(ddata->regmap, MT6360_PMU_DEV_INFO, &info);
> - if (ret < 0)
> + if (ret < 0) {
> + dev_err(ddata->dev, "Failed to read device info from regmap\n");
I'm not fussed about this change either, but if you insist, please
change the commit message to be a little more generic. Users don't
care about Regmaps and developers can grep it in the source.
Suggest: "Failed to fetch device information from H/W"
> return ret;
> + }
>
> if ((info & CHIP_VEN_MASK) != CHIP_VEN_MT6360) {
> dev_err(ddata->dev, "Device not supported\n");
--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
Powered by blists - more mailing lists