lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Mon, 19 Jul 2021 14:53:39 -0700
From:   Reinette Chatre <reinette.chatre@...el.com>
To:     "Fabio M. De Francesco" <fmdefrancesco@...il.com>,
        Fenghua Yu <fenghua.yu@...el.com>,
        Thomas Gleixner <tglx@...utronix.de>,
        Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
        <x86@...nel.org>, "H. Peter Anvin" <hpa@...or.com>,
        <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] x86/resctrl: Fix kernel-doc in rdtgroup.c

Hi Fabio,

Thank you very much for continuing these fixes.

On 7/7/2021 4:29 AM, Fabio M. De Francesco wrote:
> Add description of undocumented parameters. Issues detected by
> scripts/kernel-doc.
> 
> Signed-off-by: Fabio M. De Francesco <fmdefrancesco@...il.com>
> ---
>   arch/x86/kernel/cpu/resctrl/rdtgroup.c | 19 +++++++++++++++++++
>   1 file changed, 19 insertions(+)
> 
> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> index 01fd30e7829d..b5a30e57ce5f 100644
> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> @@ -877,6 +877,9 @@ static int rdt_shareable_bits_show(struct kernfs_open_file *of,
>   
>   /**
>    * rdt_bit_usage_show - Display current usage of resources
> + * @of: kernfs open file

This description just seems like a rewrite of the type. How about:
@of: pointer to opened "bit_usage" info file

> + * @seq: seq_file for kernfs

@seq: seq_file used to format output to "bit_usage"

> + * @v: unused pointer to void
>    *
>    * A domain is a shared resource that can now be allocated differently. Here
>    * we display the current regions of the domain as an annotated bitmask.
> @@ -888,6 +891,8 @@ static int rdt_shareable_bits_show(struct kernfs_open_file *of,
>    *   S - currently used and shareable by software only
>    *   E - currently used exclusively by one resource group
>    *   P - currently pseudo-locked by one resource group
> + *
> + * Return: 0 on success

This function always returns 0. It can just be:
Return: 0

>    */
>   static int rdt_bit_usage_show(struct kernfs_open_file *of,
>   			      struct seq_file *seq, void *v)
> @@ -1243,6 +1248,7 @@ bool rdtgroup_cbm_overlaps(struct rdt_resource *r, struct rdt_domain *d,
>   
>   /**
>    * rdtgroup_mode_test_exclusive - Test if this resource group can be exclusive
> + * @rdtgrp: resource director technology group

Just "resource group" please.

>    *
>    * An exclusive resource group implies that there should be no sharing of
>    * its allocated resources. At the time this group is considered to be
> @@ -1283,7 +1289,12 @@ static bool rdtgroup_mode_test_exclusive(struct rdtgroup *rdtgrp)
>   
>   /**
>    * rdtgroup_mode_write - Modify the resource group's mode
> + * @of: open file in kernfs

@of: pointer to opened "mode" file of a resource group

> + * @buf: input data buffer

@buf: data from user space

> + * @nbytes: lenght of input data buffer

lenght -> length

> + * @off: offset

Just writing "offset" is quite cryptic. While an offset to a write may 
be intuitive I think it would be valuable to add that this is not 
used/supported.

>    *
> + * Return: @nbytes on success, <0 on failure
>    */
>   static ssize_t rdtgroup_mode_write(struct kernfs_open_file *of,
>   				   char *buf, size_t nbytes, loff_t off)
> @@ -1367,6 +1378,8 @@ static ssize_t rdtgroup_mode_write(struct kernfs_open_file *of,
>    *
>    * @cbm is unsigned long, even if only 32 bits are used to make the
>    * bitmap functions work correctly.
> + *
> + * Return: how many bytes are represented by the bitmask associated with the RDT domain.
>    */

Could you please change to "how many bytes of the cache are represented 
by @cbm"?

>   unsigned int rdtgroup_cbm_to_size(struct rdt_resource *r,
>   				  struct rdt_domain *d, unsigned long cbm)
> @@ -1389,10 +1402,14 @@ unsigned int rdtgroup_cbm_to_size(struct rdt_resource *r,
>   
>   /**
>    * rdtgroup_size_show - Display size in bytes of allocated regions
> + * @of: open file in kernfs

@of: pointer to opened "size" file of a resource group

> + * @s: seq_file

@seq: seq_file used to format output to "size"

> + * @v: unused pointer to void
>    *
>    * The "size" file mirrors the layout of the "schemata" file, printing the
>    * size in bytes of each region instead of the capacity bitmask.
>    *
> + * Return: 0 on success, <0 on failure
>    */
>   static int rdtgroup_size_show(struct kernfs_open_file *of,
>   			      struct seq_file *s, void *v)
> @@ -2618,6 +2635,8 @@ static int mkdir_mondata_all(struct kernfs_node *parent_kn,
>    * resource group is initialized. The user can follow this with a
>    * modification to the CBM if the default does not satisfy the
>    * requirements.
> + *
> + * Return: A bitmap representing a valid contiguous CBM, 0 if @_val is only 0 filled
>    */

A valid CBM is one that consists out of contiguous 1s. So perhaps this 
could be simplified as: "Return: A valid CBM, ..."

>   static u32 cbm_ensure_valid(u32 _val, struct rdt_resource *r)
>   {
> 

Thank you very much

Reinette

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ