[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <aec911b055687892897feb4899644b9463245f1e.1627413010.git.benjamin.philip495@gmail.com>
Date: Wed, 28 Jul 2021 00:49:51 +0530
From: Benjamin Philip <benjamin.philip495@...il.com>
To: Sudip Mukherjee <sudipm.mukherjee@...il.com>,
Teddy Wang <teddy.wang@...iconmotion.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: linux-fbdev@...r.kernel.org, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org,
Benjamin Philip <benjamin.philip495@...il.com>
Subject: [PATCH 2/4] staging: sm750fb: Rename oCursor to o_cursor in lynxfb_crtc
The struct lynxfb_crtc has a member named oCursor. This name is
CamelCase and is frowned upon. This commit renames it to o_cursor
and makes the necessary changes for the module to build.
This change also fixes the following checkpatch CHECK:
CHECK: Avoid CamelCase: <oCursor>
137: FILE: sm750.h:137:
+ int oCursor; /* cursor address offset in vidmem */
Signed-off-by: Benjamin Philip <benjamin.philip495@...il.com>
---
drivers/staging/sm750fb/sm750.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
index 08c1048be541..4093d5e898c6 100644
--- a/drivers/staging/sm750fb/sm750.h
+++ b/drivers/staging/sm750fb/sm750.h
@@ -134,7 +134,7 @@ struct lynx_cursor {
struct lynxfb_crtc {
unsigned char __iomem *vCursor; /* virtual address of cursor */
unsigned char __iomem *vScreen; /* virtual address of on_screen */
- int oCursor; /* cursor address offset in vidmem */
+ int o_cursor; /* cursor address offset in vidmem */
int o_screen; /* onscreen address offset in vidmem */
int channel;/* which channel this crtc stands for*/
resource_size_t vidmem_size;/* this view's video memory max size */
--
2.31.1
Powered by blists - more mailing lists