lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 28 Jul 2021 09:19:16 +0200
From:   Alex Ghiti <alex@...ti.fr>
To:     Kenneth Lee <nek.in.cn@...il.com>,
        Paul Walmsley <paul.walmsley@...ive.com>,
        Palmer Dabbelt <palmer@...belt.com>,
        Albert Ou <aou@...s.berkeley.edu>,
        Anup Patel <anup@...infault.org>,
        Atish Patra <atish.patra@....com>,
        Kenneth Lee <liguozhu@...ilicon.com>,
        Kefeng Wang <wangkefeng.wang@...wei.com>,
        Vitaly Wool <vitaly.wool@...sulko.com>,
        Guo Ren <guoren@...ux.alibaba.com>,
        Jisheng Zhang <jszhang@...nel.org>,
        Mike Rapoport <rppt@...nel.org>,
        Nick Kossifidis <mick@....forth.gr>,
        linux-riscv@...ts.infradead.org, linux-kernel@...r.kernel.org
Cc:     guohanjun@...wei.com, wangzhou1@...ilicon.com
Subject: Re: [PATCH] riscv: fix the global name pfn_base confliction error

Hi Kenneth,

Le 28/07/2021 à 08:43, Kenneth Lee a écrit :
> From: Kenneth Lee <liguozhu@...ilicon.com>
> 
> RISCV use a global variable pfn_base for page/pfn translation. But this
> is a common name and will be used elsewhere. In those case,
> the page-pfn macro which refer this name will refer to the local/input
> variable of those function (such as in vfio_pin_pages_remote). This make
> everything wrong.
> 
> This patch change the name from pfn_base to riscv_global_pfn_base to fix
> this problem

What about removing this variable entirely and using 
PFN_DOWN(kernel_map.phys_addr) directly in ARCH_PFN_OFFSET definition? 
That would remove code from mm/init.c, which is nice :)

Thanks,

Alex

> 
> Signed-off-by: Kenneth Lee <liguozhu@...ilicon.com>
> ---
>   arch/riscv/include/asm/page.h | 4 ++--
>   arch/riscv/mm/init.c          | 6 +++---
>   2 files changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/arch/riscv/include/asm/page.h b/arch/riscv/include/asm/page.h
> index cca8764aed83..8711e415f37c 100644
> --- a/arch/riscv/include/asm/page.h
> +++ b/arch/riscv/include/asm/page.h
> @@ -79,8 +79,8 @@ typedef struct page *pgtable_t;
>   #endif
>   
>   #ifdef CONFIG_MMU
> -extern unsigned long pfn_base;
> -#define ARCH_PFN_OFFSET		(pfn_base)
> +extern unsigned long riscv_global_pfn_base;
> +#define ARCH_PFN_OFFSET		(riscv_global_pfn_base)
>   #else
>   #define ARCH_PFN_OFFSET		(PAGE_OFFSET >> PAGE_SHIFT)
>   #endif /* CONFIG_MMU */
> diff --git a/arch/riscv/mm/init.c b/arch/riscv/mm/init.c
> index a14bf3910eec..2ce4e9a46ca0 100644
> --- a/arch/riscv/mm/init.c
> +++ b/arch/riscv/mm/init.c
> @@ -228,8 +228,8 @@ static struct pt_alloc_ops _pt_ops __initdata;
>   #define pt_ops _pt_ops
>   #endif
>   
> -unsigned long pfn_base __ro_after_init;
> -EXPORT_SYMBOL(pfn_base);
> +unsigned long riscv_global_pfn_base __ro_after_init;
> +EXPORT_SYMBOL(riscv_global_pfn_base);
>   
>   pgd_t swapper_pg_dir[PTRS_PER_PGD] __page_aligned_bss;
>   pgd_t trampoline_pg_dir[PTRS_PER_PGD] __page_aligned_bss;
> @@ -572,7 +572,7 @@ asmlinkage void __init setup_vm(uintptr_t dtb_pa)
>   	kernel_map.va_kernel_pa_offset = kernel_map.virt_addr - kernel_map.phys_addr;
>   #endif
>   
> -	pfn_base = PFN_DOWN(kernel_map.phys_addr);
> +	riscv_global_pfn_base = PFN_DOWN(kernel_map.phys_addr);
>   
>   	/*
>   	 * Enforce boot alignment requirements of RV32 and
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ