[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210728081320.20394-1-wangkefeng.wang@huawei.com>
Date: Wed, 28 Jul 2021 16:13:13 +0800
From: Kefeng Wang <wangkefeng.wang@...wei.com>
To: <arnd@...db.de>, <linux-arch@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, <linuxppc-dev@...ts.ozlabs.org>,
<rostedt@...dmis.org>, <mingo@...hat.com>, <davem@...emloft.net>,
<ast@...nel.org>, <ryabinin.a.a@...il.com>
CC: <mpe@...erman.id.au>, <benh@...nel.crashing.org>,
<paulus@...ba.org>, Kefeng Wang <wangkefeng.wang@...wei.com>,
<linux-s390@...r.kernel.org>, <iommu@...ts.linux-foundation.org>,
<bpf@...r.kernel.org>
Subject: [PATCH v2 0/7] sections: Unify kernel sections range check and use
There are three head files(kallsyms.h, kernel.h and sections.h) which
include the kernel sections range check, let's make some cleanup and
unify them.
1. cleanup arch specific text/data check and fix address boundary check
in kallsyms.h
2. make all the basic/core kernel range check function into sections.h
3. update all the callers, and use the helper in sections.h to simplify
the code
After this series, we have 5 APIs about kernel sections range check in
sections.h
* is_kernel_core_data() --- come from core_kernel_data() in kernel.h
* is_kernel_rodata() --- already in sections.h
* is_kernel_text() --- come from kallsyms.h
* is_kernel_inittext() --- come from kernel.h and kallsyms.h
* is_kernel() --- come from kallsyms.h
Cc: linuxppc-dev@...ts.ozlabs.org
Cc: linux-s390@...r.kernel.org
Cc: linux-arch@...r.kernel.org
Cc: iommu@...ts.linux-foundation.org
Cc: bpf@...r.kernel.org
v2:
- add ACK/RW to patch2, and drop inappropriate fix tag
- keep 'core' to check kernel data, suggestted by Steven Rostedt
<rostedt@...dmis.org>, rename is_kernel_data() to is_kernel_core_data()
- drop patch8 which is merged
- drop patch9 which is resend independently
v1:
https://lore.kernel.org/linux-arch/20210626073439.150586-1-wangkefeng.wang@huawei.com
Kefeng Wang (7):
kallsyms: Remove arch specific text and data check
kallsyms: Fix address-checks for kernel related range
sections: Move and rename core_kernel_data() to is_kernel_core_data()
sections: Move is_kernel_inittext() into sections.h
kallsyms: Rename is_kernel() and is_kernel_text()
sections: Add new is_kernel() and is_kernel_text()
powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper
arch/powerpc/mm/pgtable_32.c | 7 +---
arch/x86/kernel/unwind_orc.c | 2 +-
arch/x86/net/bpf_jit_comp.c | 2 +-
include/asm-generic/sections.h | 71 ++++++++++++++++++++++++++--------
include/linux/kallsyms.h | 21 +++-------
include/linux/kernel.h | 2 -
kernel/cfi.c | 2 +-
kernel/extable.c | 33 ++--------------
kernel/locking/lockdep.c | 3 --
kernel/trace/ftrace.c | 2 +-
mm/kasan/report.c | 2 +-
net/sysctl_net.c | 2 +-
12 files changed, 72 insertions(+), 77 deletions(-)
--
2.26.2
Powered by blists - more mailing lists