[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b352a416-ca6b-0665-9a9e-621686e0353a@nvidia.com>
Date: Sun, 8 Aug 2021 23:36:47 -0700
From: John Hubbard <jhubbard@...dia.com>
To: Christoph Hellwig <hch@...radead.org>
CC: Andrew Morton <akpm@...ux-foundation.org>,
Matthew Wilcox <willy@...radead.org>,
LKML <linux-kernel@...r.kernel.org>, <linux-mm@...ck.org>
Subject: Re: [PATCH 3/3] mm/gup: refactor and simplify try_get_page()
On 8/8/21 11:29 PM, Christoph Hellwig wrote:
> On Sun, Aug 08, 2021 at 04:50:18PM -0700, John Hubbard wrote:
>> +/*
>> + * This has the same functionality as try_get_compound_head(), just with a
>> + * slightly different API.
>> + */
>> static inline __must_check bool try_get_page(struct page *page)
>> {
>> + return try_get_compound_head(page, 1) != NULL;
>
> What about removing try_get_page entirely instead?
>
This thought admittedly crossed my mind, but I was worried maybe I was
getting carried away with cleanups. But now that at least one other
person thinks that's reasonable, I'll be glad to cleanup the callers
too.
thanks,
--
John Hubbard
NVIDIA
Powered by blists - more mailing lists