lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Tue, 10 Aug 2021 14:33:17 +0100 From: Marc Zyngier <maz@...nel.org> To: Anshuman Khandual <anshuman.khandual@....com> Cc: linux-arm-kernel@...ts.infradead.org, James Morse <james.morse@....com>, Alexandru Elisei <alexandru.elisei@....com>, Suzuki K Poulose <suzuki.poulose@....com>, Catalin Marinas <catalin.marinas@....com>, Will Deacon <will@...nel.org>, kvmarm@...ts.cs.columbia.edu, linux-kernel@...r.kernel.org Subject: Re: [PATCH 1/5] KVM: arm64: Drop direct PAGE_[SHIFT|SIZE] usage as page size On 2021-08-10 08:02, Anshuman Khandual wrote: > All instances here could just directly test against > CONFIG_ARM64_XXK_PAGES > instead of evaluating via PAGE_SHIFT or PAGE_SIZE. With this change, > there > will be no such usage left. > > Cc: Marc Zyngier <maz@...nel.org> > Cc: James Morse <james.morse@....com> > Cc: Alexandru Elisei <alexandru.elisei@....com> > Cc: Suzuki K Poulose <suzuki.poulose@....com> > Cc: Catalin Marinas <catalin.marinas@....com> > Cc: Will Deacon <will@...nel.org> > Cc: linux-arm-kernel@...ts.infradead.org > Cc: kvmarm@...ts.cs.columbia.edu > Cc: linux-kernel@...r.kernel.org > Signed-off-by: Anshuman Khandual <anshuman.khandual@....com> > --- > arch/arm64/kvm/hyp/pgtable.c | 6 +++--- > arch/arm64/mm/mmu.c | 2 +- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/arch/arm64/kvm/hyp/pgtable.c > b/arch/arm64/kvm/hyp/pgtable.c > index 05321f4165e3..a6112b6d6ef6 100644 > --- a/arch/arm64/kvm/hyp/pgtable.c > +++ b/arch/arm64/kvm/hyp/pgtable.c > @@ -85,7 +85,7 @@ static bool kvm_level_supports_block_mapping(u32 > level) > * Reject invalid block mappings and don't bother with 4TB mappings > for > * 52-bit PAs. > */ > - return !(level == 0 || (PAGE_SIZE != SZ_4K && level == 1)); > + return !(level == 0 || (!IS_ENABLED(CONFIG_ARM64_4K_PAGES) && level > == 1)); > } > > static bool kvm_block_mapping_supported(u64 addr, u64 end, u64 phys, > u32 level) > @@ -155,7 +155,7 @@ static u64 kvm_pte_to_phys(kvm_pte_t pte) > { > u64 pa = pte & KVM_PTE_ADDR_MASK; > > - if (PAGE_SHIFT == 16) > + if (IS_ENABLED(CONFIG_ARM64_64K_PAGES)) > pa |= FIELD_GET(KVM_PTE_ADDR_51_48, pte) << 48; > > return pa; > @@ -165,7 +165,7 @@ static kvm_pte_t kvm_phys_to_pte(u64 pa) > { > kvm_pte_t pte = pa & KVM_PTE_ADDR_MASK; > > - if (PAGE_SHIFT == 16) > + if (IS_ENABLED(CONFIG_ARM64_64K_PAGES)) > pte |= FIELD_PREP(KVM_PTE_ADDR_51_48, pa >> 48); > > return pte; > diff --git a/arch/arm64/mm/mmu.c b/arch/arm64/mm/mmu.c > index 9ff0de1b2b93..8fdfca179815 100644 > --- a/arch/arm64/mm/mmu.c > +++ b/arch/arm64/mm/mmu.c > @@ -296,7 +296,7 @@ static void alloc_init_cont_pmd(pud_t *pudp, > unsigned long addr, > static inline bool use_1G_block(unsigned long addr, unsigned long > next, > unsigned long phys) > { > - if (PAGE_SHIFT != 12) > + if (!IS_ENABLED(CONFIG_ARM64_4K_PAGES)) > return false; > > if (((addr | next | phys) & ~PUD_MASK) != 0) I personally find it a lot less readable. Also, there is no evaluation whatsoever. All the code guarded by a PAGE_SIZE/PAGE_SHIFT that doesn't match the configuration is dropped at compile time. Thanks, M. -- Jazz is not dead. It just smells funny...
Powered by blists - more mailing lists