[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YRPxwC99/jjZE8pO@zn.tnic>
Date: Wed, 11 Aug 2021 17:50:24 +0200
From: Borislav Petkov <bp@...en8.de>
To: James Morse <james.morse@....com>
Cc: x86@...nel.org, linux-kernel@...r.kernel.org,
Fenghua Yu <fenghua.yu@...el.com>,
Reinette Chatre <reinette.chatre@...el.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, H Peter Anvin <hpa@...or.com>,
Babu Moger <Babu.Moger@....com>,
shameerali.kolothum.thodi@...wei.com,
Jamie Iles <jamie@...iainc.com>,
D Scott Phillips OS <scott@...amperecomputing.com>,
lcherian@...vell.com, bobo.shaobowang@...wei.com
Subject: Re: [PATCH v7 16/24] x86/resctrl: Add a helper to read a closid's
configuration
On Wed, Jul 28, 2021 at 05:06:29PM +0000, James Morse wrote:
> +void resctrl_arch_get_config(struct rdt_resource *r, struct rdt_domain *d,
> + u32 closid, u32 *value)
> +{
> + struct rdt_hw_domain *hw_dom = resctrl_to_arch_dom(d);
> +
> + if (!is_mba_sc(r))
> + *value = hw_dom->ctrl_val[closid];
> + else
> + *value = hw_dom->mbps_val[closid];
I don't like functions which are of void type but which still return a
value through an arg pointer. Please send a cleanup ontop of the whole
set converting it to return u32 as the mbps value instead.
Thx.
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette
Powered by blists - more mailing lists