[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210816105119.704302-4-hpa@redhat.com>
Date: Mon, 16 Aug 2021 18:51:02 +0800
From: Kate Hsuan <hpa@...hat.com>
To: Alex Hung <alex.hung@...onical.com>,
Hans de Goede <hdegoede@...hat.com>,
Mark Gross <mgross@...ux.intel.com>,
Srinivas Pandruvada <srinivas.pandruvada@...ux.intel.com>,
AceLan Kao <acelan.kao@...onical.com>,
Jithu Joseph <jithu.joseph@...el.com>,
Maurice Ma <maurice.ma@...el.com>,
Sujith Thomas <sujith.thomas@...el.com>,
Rajneesh Bhardwaj <irenic.rajneesh@...il.com>,
Zha Qipeng <qipeng.zha@...el.com>,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
"David E . Box" <david.e.box@...ux.intel.com>,
linux-kernel@...r.kernel.org, Dell.Client.Kernel@...l.com
Cc: platform-driver-x86@...r.kernel.org, Kate Hsuan <hpa@...hat.com>
Subject: [PATCH v2 03/20] platform/x86: intel_mrfld_pwrbtn: Move to intel sub-directory
Move intel_mrfld_pwrbtn to intel sub-directory
to improve readability.
Signed-off-by: Kate Hsuan <hpa@...hat.com>
---
drivers/platform/x86/Kconfig | 11 -----------
drivers/platform/x86/Makefile | 1 -
drivers/platform/x86/intel/Kconfig | 11 +++++++++++
drivers/platform/x86/intel/Makefile | 2 ++
.../{intel_mrfld_pwrbtn.c => intel/mrfld_pwrbtn.c} | 0
5 files changed, 13 insertions(+), 12 deletions(-)
rename drivers/platform/x86/{intel_mrfld_pwrbtn.c => intel/mrfld_pwrbtn.c} (100%)
diff --git a/drivers/platform/x86/Kconfig b/drivers/platform/x86/Kconfig
index 0b49cb62514a..66cc8a8a9bae 100644
--- a/drivers/platform/x86/Kconfig
+++ b/drivers/platform/x86/Kconfig
@@ -1168,17 +1168,6 @@ config INTEL_UNCORE_FREQ_CONTROL
To compile this driver as a module, choose M here: the module
will be called intel-uncore-frequency.
-config INTEL_MRFLD_PWRBTN
- tristate "Intel Merrifield Basin Cove power button driver"
- depends on INTEL_SOC_PMIC_MRFLD
- depends on INPUT
- help
- This option adds a power button driver for Basin Cove PMIC
- on Intel Merrifield devices.
-
- To compile this driver as a module, choose M here: the module
- will be called intel_mrfld_pwrbtn.
-
config INTEL_PMC_CORE
tristate "Intel PMC Core driver"
depends on PCI
diff --git a/drivers/platform/x86/Makefile b/drivers/platform/x86/Makefile
index 683e3abaa8e6..fb6dc4d9e8df 100644
--- a/drivers/platform/x86/Makefile
+++ b/drivers/platform/x86/Makefile
@@ -129,7 +129,6 @@ obj-$(CONFIG_INTEL_UNCORE_FREQ_CONTROL) += intel-uncore-frequency.o
# Intel PMIC / PMC / P-Unit devices
-obj-$(CONFIG_INTEL_MRFLD_PWRBTN) += intel_mrfld_pwrbtn.o
obj-$(CONFIG_INTEL_PMC_CORE) += intel_pmc_core.o intel_pmc_core_pltdrv.o
obj-$(CONFIG_INTEL_PUNIT_IPC) += intel_punit_ipc.o
obj-$(CONFIG_INTEL_SCU_IPC) += intel_scu_ipc.o
diff --git a/drivers/platform/x86/intel/Kconfig b/drivers/platform/x86/intel/Kconfig
index 0a3ca61db14f..c4f7518d747b 100644
--- a/drivers/platform/x86/intel/Kconfig
+++ b/drivers/platform/x86/intel/Kconfig
@@ -41,4 +41,15 @@ config INTEL_CHTDC_TI_PWRBTN
To compile this driver as a module, choose M here: the module
will be called intel_chtdc_ti_pwrbtn.
+config INTEL_MRFLD_PWRBTN
+ tristate "Intel Merrifield Basin Cove power button driver"
+ depends on INTEL_SOC_PMIC_MRFLD
+ depends on INPUT
+ help
+ This option adds a power button driver for Basin Cove PMIC
+ on Intel Merrifield devices.
+
+ To compile this driver as a module, choose M here: the module
+ will be called intel_mrfld_pwrbtn.
+
endif # X86_PLATFORM_DRIVERS_INTEL
diff --git a/drivers/platform/x86/intel/Makefile b/drivers/platform/x86/intel/Makefile
index e0bbb855e08b..d194327565fe 100644
--- a/drivers/platform/x86/intel/Makefile
+++ b/drivers/platform/x86/intel/Makefile
@@ -13,3 +13,5 @@ intel_bxtwc_tmu-y := bxtwc_tmu.o
obj-$(CONFIG_INTEL_BXTWC_PMIC_TMU) += intel_bxtwc_tmu.o
intel_chtdc_ti_pwrbtn-y := chtdc_ti_pwrbtn.o
obj-$(CONFIG_INTEL_CHTDC_TI_PWRBTN) += intel_chtdc_ti_pwrbtn.o
+intel_mrfld_pwrbtn-y := mrfld_pwrbtn.o
+obj-$(CONFIG_INTEL_MRFLD_PWRBTN) += intel_mrfld_pwrbtn.o
diff --git a/drivers/platform/x86/intel_mrfld_pwrbtn.c b/drivers/platform/x86/intel/mrfld_pwrbtn.c
similarity index 100%
rename from drivers/platform/x86/intel_mrfld_pwrbtn.c
rename to drivers/platform/x86/intel/mrfld_pwrbtn.c
--
2.31.1
Powered by blists - more mailing lists