[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210816115430.28264-3-straube.linux@gmail.com>
Date: Mon, 16 Aug 2021 13:54:29 +0200
From: Michael Straube <straube.linux@...il.com>
To: gregkh@...uxfoundation.org
Cc: Larry.Finger@...inger.net, phil@...lpotter.co.uk, martin@...ser.cx,
fmdefrancesco@...il.com, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org,
Michael Straube <straube.linux@...il.com>
Subject: [PATCH v2 3/4] staging: r8188eu: refactor rtw_is_cckratesonly_included()
Refactor function rtw_is_cckratesonly_included(). Improves readability
and slightly reduces object file size.
Signed-off-by: Michael Straube <straube.linux@...il.com>
---
v1 -> v2
Refactored to more compact code as suggested by Joe Perches.
drivers/staging/r8188eu/core/rtw_ieee80211.c | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/r8188eu/core/rtw_ieee80211.c b/drivers/staging/r8188eu/core/rtw_ieee80211.c
index 53556f1af425..b1427e70cdf7 100644
--- a/drivers/staging/r8188eu/core/rtw_ieee80211.c
+++ b/drivers/staging/r8188eu/core/rtw_ieee80211.c
@@ -82,13 +82,11 @@ bool rtw_is_cckrates_included(u8 *rate)
uint rtw_is_cckratesonly_included(u8 *rate)
{
- u32 i = 0;
+ u8 r;
- while (rate[i] != 0) {
- if ((((rate[i]) & 0x7f) != 2) && (((rate[i]) & 0x7f) != 4) &&
- (((rate[i]) & 0x7f) != 11) && (((rate[i]) & 0x7f) != 22))
+ while ((r = *rate++ & 0x7f)) {
+ if (r != 2 && r != 4 && r != 11 && r != 22)
return false;
- i++;
}
return true;
--
2.32.0
Powered by blists - more mailing lists