[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <6c7e2274-98d7-721b-498b-6c5fac2a3561@redhat.com>
Date: Tue, 17 Aug 2021 16:03:32 +0200
From: David Hildenbrand <david@...hat.com>
To: Liam Howlett <liam.howlett@...cle.com>,
"linux-mm@...ck.org" <linux-mm@...ck.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [PATCH] remap_file_pages: Use vma_lookup() instead of find_vma()
On 17.08.21 15:52, Liam Howlett wrote:
> From: "Liam R. Howlett" <Liam.Howlett@...cle.com>
>
> Using vma_lookup() verifies the start address is contained in the found vma.
> This results in easier to read code.
>
> Signed-off-by: Liam R. Howlett <Liam.Howlett@...cle.com>
> ---
> mm/mmap.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/mm/mmap.c b/mm/mmap.c
> index d9aa54be6244..1a23d4575cc4 100644
> --- a/mm/mmap.c
> +++ b/mm/mmap.c
> @@ -2994,14 +2994,11 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
> if (mmap_write_lock_killable(mm))
> return -EINTR;
>
> - vma = find_vma(mm, start);
> + vma = vma_lookup(mm, start);
>
> if (!vma || !(vma->vm_flags & VM_SHARED))
> goto out;
>
> - if (start < vma->vm_start)
> - goto out;
> -
> if (start + size > vma->vm_end) {
> struct vm_area_struct *next;
>
>
Reviewed-by: David Hildenbrand <david@...hat.com>
--
Thanks,
David / dhildenb
Powered by blists - more mailing lists