[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5f3aa3fa-e877-02d1-8721-debbe688e7af@redhat.com>
Date: Thu, 2 Sep 2021 09:28:42 +0200
From: David Hildenbrand <david@...hat.com>
To: Peter Xu <peterx@...hat.com>, linux-kernel@...r.kernel.org,
linux-mm@...ck.org
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Matthew Wilcox <willy@...radead.org>,
Yang Shi <shy828301@...il.com>,
Miaohe Lin <linmiaohe@...wei.com>,
Hugh Dickins <hughd@...gle.com>,
Mike Rapoport <rppt@...ux.vnet.ibm.com>,
Andrea Arcangeli <aarcange@...hat.com>,
"Kirill A . Shutemov" <kirill@...temov.name>,
Jerome Glisse <jglisse@...hat.com>,
Alistair Popple <apopple@...dia.com>
Subject: Re: [PATCH 4/5] mm: Introduce zap_details.zap_flags
On 01.09.21 22:57, Peter Xu wrote:
> Instead of trying to introduce one variable for every new zap_details fields,
> let's introduce a flag so that it can start to encode true/false informations.
>
> Let's start to use this flag first to clean up the only check_mapping variable.
> Firstly, the name "check_mapping" implies this is a "boolean", but actually it
> stores the mapping inside, just in a way that it won't be set if we don't want
> to check the mapping.
>
> To make things clearer, introduce the 1st zap flag ZAP_FLAG_CHECK_MAPPING, so
> that we only check against the mapping if this bit set. At the same time, we
> can rename check_mapping into zap_mapping and set it always.
>
> Since at it, introduce another helper zap_check_mapping_skip() and use it in
> zap_pte_range() properly.
>
> Some old comments have been removed in zap_pte_range() because they're
> duplicated, and since now we're with ZAP_FLAG_CHECK_MAPPING flag, it'll be very
> easy to grep this information by simply grepping the flag.
>
> It'll also make life easier when we want to e.g. pass in zap_flags into the
> callers like unmap_mapping_pages() (instead of adding new booleans besides the
> even_cows parameter).
>
> Signed-off-by: Peter Xu <peterx@...hat.com>
> ---
> include/linux/mm.h | 19 ++++++++++++++++++-
> mm/memory.c | 34 ++++++++++------------------------
> 2 files changed, 28 insertions(+), 25 deletions(-)
>
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 69259229f090..fcbc1c4f8e8e 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -1716,14 +1716,31 @@ static inline bool can_do_mlock(void) { return false; }
> extern int user_shm_lock(size_t, struct ucounts *);
> extern void user_shm_unlock(size_t, struct ucounts *);
>
> +/* Whether to check page->mapping when zapping */
> +#define ZAP_FLAG_CHECK_MAPPING BIT(0)
So we want to go full way, like:
typedef int __bitwise zap_flags_t;
#define ZAP_FLAG_CHECK_MAPPING ((__force zap_flags_t)BIT(0))
> +
> /*
> * Parameter block passed down to zap_pte_range in exceptional cases.
> */
> struct zap_details {
> - struct address_space *check_mapping; /* Check page->mapping if set */
> + struct address_space *zap_mapping;
> struct page *single_page; /* Locked page to be unmapped */
> + unsigned long zap_flags;
Why call it "zap_*" if everything in the structure is related to
zapping? IOW, simply "mapping", "flags" would be good enough.
> };
>
> +/* Return true if skip zapping this page, false otherwise */
> +static inline bool
> +zap_skip_check_mapping(struct zap_details *details, struct page *page)
> +{
> + if (!details || !page)
> + return false;
> +
> + if (!(details->zap_flags & ZAP_FLAG_CHECK_MAPPING))
> + return false;
> +
> + return details->zap_mapping != page_rmapping(page);
> +}
I'm confused, why isn't "!details->zap_mapping" vs.
"details->zap_mapping" sufficient? I can see that you may need flags for
other purposes (next patch), but why do we need it here?
Factoring it out into this helper is a nice cleanup, though. But I'd
just not introduce ZAP_FLAG_CHECK_MAPPING.
--
Thanks,
David / dhildenb
Powered by blists - more mailing lists