[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210914013858.31192-1-nicoleotsuka@gmail.com>
Date: Mon, 13 Sep 2021 18:38:52 -0700
From: Nicolin Chen <nicoleotsuka@...il.com>
To: thierry.reding@...il.com, joro@...tes.org, will@...nel.org
Cc: vdumpa@...dia.com, jonathanh@...dia.com,
linux-tegra@...r.kernel.org, iommu@...ts.linux-foundation.org,
linux-kernel@...r.kernel.org, digetx@...il.com
Subject: [PATCH v6 0/6] iommu/tegra-smmu: Add pagetable mappings to debugfs
This series of patches adds a new mappings node to debugfs for
tegra-smmu driver. The first five patches are all preparational
changes for PATCH-6, based on Thierry's review feedback against
v5: https://lkml.org/lkml/2021/3/16/447
Changelog
v6:
* Added PATCH1-3 for better naming conventions
* Added PATCH4-5 to embed previous struct tegra_smmu_group_debug
into struct tegra_smmu_group
* Dropped parentheses at SMMU_PTE_ATTR_SHIFT
* Dropped swgrp->reg print
* Replaced ptb_reg contents with as->attr and as->pd_dma
* Added "index" and "count" in the PD entries for readability
* Removed Dmitry's Tested-by and Reviewed-by for the big change
from v5 to v6.
v5: https://lkml.org/lkml/2021/3/15/2473
* Fixed a typo in commit message
* Split a long line into two lines
* Rearranged variable defines by length
* Added Tested-by and Reviewed-by from Dmitry
v4: https://lkml.org/lkml/2021/3/14/429
* Changed %d to %u for unsigned variables
* Fixed print format mismatch warnings on ARM32
v3: https://lkml.org/lkml/2021/3/14/30
* Fixed PHYS and IOVA print formats
* Changed variables to unsigned int type
* Changed the table outputs to be compact
v2: https://lkml.org/lkml/2021/3/9/1382
* Expanded mutex range to the entire function
* Added as->lock to protect pagetable walkthrough
* Replaced devm_kzalloc with devm_kcalloc for group_debug
* Added "PTE RANGE" and "SIZE" columns to group contiguous mappings
* Dropped as->count check
* Added WARN_ON when as->count mismatches pd[pd_index]
v1: https://lkml.org/lkml/2020/9/26/70
Nicolin Chen (6):
iommu/tegra-smmu: Rename struct iommu_group *group to *grp
iommu/tegra-smmu: Rename struct tegra_smmu_group_soc *soc to
*group_soc
iommu/tegra-smmu: Rename struct tegra_smmu_swgroup *group to *swgrp
iommu/tegra-smmu: Use swgrp pointer instead of swgroup id
iommu/tegra-smmu: Attach as pointer to tegra_smmu_group
iommu/tegra-smmu: Add pagetable mappings to debugfs
drivers/iommu/tegra-smmu.c | 312 +++++++++++++++++++++++++++++++------
1 file changed, 262 insertions(+), 50 deletions(-)
--
2.17.1
Powered by blists - more mailing lists