[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210921143414.70723-1-sxwjean@me.com>
Date: Tue, 21 Sep 2021 22:34:12 +0800
From: sxwjean@...com
To: x86@...nel.org, linux-mm@...ck.org
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de, hpa@...or.com,
luto@...nel.org, krisman@...labora.com, chang.seok.bae@...el.com,
viro@...iv.linux.org.uk, nivedita@...m.mit.edu,
adobriyan@...il.com, oleg@...hat.com, sblbir@...zon.com,
axboe@...nel.dk, laijs@...ux.alibaba.com,
dave.hansen@...ux.intel.com, peterz@...radead.org,
akpm@...ux-foundation.org, arnd@...db.de, davem@...emloft.net,
keescook@...omium.org, kim.phillips@....com, yazen.ghannam@....com,
dave@...olabs.net, metze@...ba.org, elver@...gle.com,
ebiederm@...ssion.com, christophe.leroy@...roup.eu,
linux-kernel@...r.kernel.org, Xiongwei Song <sxwjean@...il.com>
Subject: [PATCH RESEND 0/2] Use generic code for randomization of virtual address of x86
From: Xiongwei Song <sxwjean@...il.com>
Hello,
The two patches are to use generic code for randomization of virtual
address of x86. Since the basic code logic of x86 is same as generic
code, so no need to implement these functions on x86, please see the
details in comments of patch 2.
Please review it.
Why resend?
Because I missed email addresses for patch 1 and 2, so resend the patches.
Sorry for the inconvenience.
Xiongwei Song (2):
x86: Rename TIF_ADDR32 to TIF_32BIT
x86/mm: Randomize va with generic arch_pick_mmap_layout()
arch/x86/Kconfig | 2 +-
arch/x86/include/asm/compat.h | 7 +-
arch/x86/include/asm/elf.h | 2 +-
arch/x86/include/asm/page_64_types.h | 6 +-
arch/x86/include/asm/processor.h | 4 +-
arch/x86/include/asm/thread_info.h | 4 +-
arch/x86/kernel/process.c | 5 --
arch/x86/kernel/process_64.c | 4 +-
arch/x86/mm/mmap.c | 112 ---------------------------
include/linux/compat.h | 4 +
mm/util.c | 18 ++++-
11 files changed, 37 insertions(+), 131 deletions(-)
--
2.30.2
Powered by blists - more mailing lists