lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Thu, 23 Sep 2021 11:47:48 +0200 From: Christophe Leroy <christophe.leroy@...roup.eu> To: Mike Rapoport <rppt@...nel.org>, Linus Torvalds <torvalds@...ux-foundation.org> Cc: devicetree@...r.kernel.org, linux-efi@...r.kernel.org, Mike Rapoport <rppt@...ux.ibm.com>, kvm@...r.kernel.org, linux-s390@...r.kernel.org, linux-sh@...r.kernel.org, linux-um@...ts.infradead.org, linux-kernel@...r.kernel.org, kasan-dev@...glegroups.com, linux-mips@...r.kernel.org, linux-mm@...ck.org, iommu@...ts.linux-foundation.org, linux-usb@...r.kernel.org, linux-alpha@...r.kernel.org, sparclinux@...r.kernel.org, xen-devel@...ts.xenproject.org, Andrew Morton <akpm@...ux-foundation.org>, linux-snps-arc@...ts.infradead.org, linuxppc-dev@...ts.ozlabs.org, linux-riscv@...ts.infradead.org, linux-arm-kernel@...ts.infradead.org Subject: Re: [PATCH 3/3] memblock: cleanup memblock_free interface Le 23/09/2021 à 09:43, Mike Rapoport a écrit : > From: Mike Rapoport <rppt@...ux.ibm.com> > > For ages memblock_free() interface dealt with physical addresses even > despite the existence of memblock_alloc_xx() functions that return a > virtual pointer. > > Introduce memblock_phys_free() for freeing physical ranges and repurpose > memblock_free() to free virtual pointers to make the following pairing > abundantly clear: > > int memblock_phys_free(phys_addr_t base, phys_addr_t size); > phys_addr_t memblock_phys_alloc(phys_addr_t base, phys_addr_t size); > > void *memblock_alloc(phys_addr_t size, phys_addr_t align); > void memblock_free(void *ptr, size_t size); > > Replace intermediate memblock_free_ptr() with memblock_free() and drop > unnecessary aliases memblock_free_early() and memblock_free_early_nid(). > > Suggested-by: Linus Torvalds <torvalds@...ux-foundation.org> > Signed-off-by: Mike Rapoport <rppt@...ux.ibm.com> > --- > diff --git a/arch/s390/kernel/smp.c b/arch/s390/kernel/smp.c > index 1a04e5bdf655..37826d8c4f74 100644 > --- a/arch/s390/kernel/smp.c > +++ b/arch/s390/kernel/smp.c > @@ -723,7 +723,7 @@ void __init smp_save_dump_cpus(void) > /* Get the CPU registers */ > smp_save_cpu_regs(sa, addr, is_boot_cpu, page); > } > - memblock_free(page, PAGE_SIZE); > + memblock_phys_free(page, PAGE_SIZE); > diag_amode31_ops.diag308_reset(); > pcpu_set_smt(0); > } > @@ -880,7 +880,7 @@ void __init smp_detect_cpus(void) > > /* Add CPUs present at boot */ > __smp_rescan_cpus(info, true); > - memblock_free_early((unsigned long)info, sizeof(*info)); > + memblock_free(info, sizeof(*info)); > } > > /* I'm a bit lost. IIUC memblock_free_early() and memblock_free() where identical. In the first hunk memblock_free() gets replaced by memblock_phys_free() In the second hunk memblock_free_early() gets replaced by memblock_free() I think it would be easier to follow if you could split it in several patches: - First patch: Create memblock_phys_free() and change all relevant memblock_free() to memblock_phys_free() - Or change memblock_free() to memblock_phys_free() and make memblock_free() an alias of it. - Second patch: Make memblock_free_ptr() become memblock_free() and change all remaining callers to the new semantics (IIUC memblock_free(__pa(ptr)) becomes memblock_free(ptr) and make memblock_free_ptr() an alias of memblock_free() - Fourth patch: Replace and drop memblock_free_ptr() - Fifth patch: Drop memblock_free_early() and memblock_free_early_nid() (All users should have been upgraded to memblock_free_phys() in patch 1 or memblock_free() in patch 2) Christophe
Powered by blists - more mailing lists