lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 23 Sep 2021 08:10:53 -0500
From:   Rob Herring <robh@...nel.org>
To:     Dikshita Agarwal <dikshita@...eaurora.org>
Cc:     robh+dt@...nel.org, linux-kernel@...r.kernel.org,
        stanimir.varbanov@...aro.org, mchehab@...nel.org,
        devicetree@...r.kernel.org, vgarodia@...eaurora.org,
        bjorn.andersson@...aro.org, linux-arm-msm@...r.kernel.org,
        agross@...nel.org, linux-media@...r.kernel.org
Subject: Re: [RESEND PATCH v3] dt-bindings: media: venus: Add sc7280 dt schema

On Thu, 23 Sep 2021 11:38:29 +0530, Dikshita Agarwal wrote:
> Add a schema description for the venus video encoder/decoder on the sc7280.
> 
> Signed-off-by: Dikshita Agarwal <dikshita@...eaurora.org>
> Reviewed-by: Rob Herring <robh@...nel.org>
> ---
>  .../bindings/media/qcom,sc7280-venus.yaml          | 159 +++++++++++++++++++++
>  1 file changed, 159 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/media/qcom,sc7280-venus.yaml
> 

My bot found errors running 'make DT_CHECKER_FLAGS=-m dt_binding_check'
on your patch (DT_CHECKER_FLAGS is new in v5.13):

yamllint warnings/errors:

dtschema/dtc warnings/errors:
Error: Documentation/devicetree/bindings/media/qcom,sc7280-venus.example.dts:24.31-32 syntax error
FATAL ERROR: Unable to parse input tree
make[1]: *** [scripts/Makefile.lib:385: Documentation/devicetree/bindings/media/qcom,sc7280-venus.example.dt.yaml] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [Makefile:1441: dt_binding_check] Error 2

doc reference errors (make refcheckdocs):

See https://patchwork.ozlabs.org/patch/1531553

This check can fail if there are any dependencies. The base for a patch
series is generally the most recent rc1.

If you already ran 'make dt_binding_check' and didn't see the above
error(s), then make sure 'yamllint' is installed and dt-schema is up to
date:

pip3 install dtschema --upgrade

Please check and re-submit.

Powered by blists - more mailing lists