lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4e4c9adf-5444-e331-fefa-0d72aea8ba57@redhat.com>
Date:   Sun, 26 Sep 2021 15:22:19 -0400
From:   Waiman Long <llong@...hat.com>
To:     Yanfei Xu <yanfei.xu@...driver.com>, peterz@...radead.org,
        mingo@...hat.com, will@...nel.org, boqun.feng@...il.com
Cc:     linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] locking/rwsem: Use rcu_read_lock_sched to simplify
 codes

On 9/26/21 6:16 AM, Yanfei Xu wrote:
> Use rcu_read_lock_sched to simplify the codes, and it also saves
> some cycles of handling rcu nesting counter.
>
> Signed-off-by: Yanfei Xu <yanfei.xu@...driver.com>
> ---
>   kernel/locking/rwsem.c | 6 ++----
>   1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/kernel/locking/rwsem.c b/kernel/locking/rwsem.c
> index 000e8d5a2884..7afadfe02286 100644
> --- a/kernel/locking/rwsem.c
> +++ b/kernel/locking/rwsem.c
> @@ -616,8 +616,7 @@ static inline bool rwsem_can_spin_on_owner(struct rw_semaphore *sem)
>   		return false;
>   	}
>   
> -	preempt_disable();
> -	rcu_read_lock();
> +	rcu_read_lock_sched();
>   	owner = rwsem_owner_flags(sem, &flags);
>   	/*
>   	 * Don't check the read-owner as the entry may be stale.
> @@ -625,8 +624,7 @@ static inline bool rwsem_can_spin_on_owner(struct rw_semaphore *sem)
>   	if ((flags & RWSEM_NONSPINNABLE) ||
>   	    (owner && !(flags & RWSEM_READER_OWNED) && !owner_on_cpu(owner)))
>   		ret = false;
> -	rcu_read_unlock();
> -	preempt_enable();
> +	rcu_read_unlock_sched();
>   
>   	lockevent_cond_inc(rwsem_opt_fail, !ret);
>   	return ret;

I don't think there is any performance gain with this change. I would 
prefer the original code that is more readable as some people may not 
know rcu_read_lock_sched() will disable preemption if they don't look 
into it.

Cheers,
Longman

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ