lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 28 Sep 2021 09:55:00 +0100
From:   Mark Rutland <mark.rutland@....com>
To:     Pingfan Liu <kernelfans@...il.com>
Cc:     linux-kernel@...r.kernel.org, Thomas Gleixner <tglx@...utronix.de>,
        Catalin Marinas <catalin.marinas@....com>,
        Will Deacon <will@...nel.org>, Marc Zyngier <maz@...nel.org>,
        Joey Gouly <joey.gouly@....com>,
        Sami Tolvanen <samitolvanen@...gle.com>,
        Julien Thierry <julien.thierry@....com>,
        Yuichi Ito <ito-yuichi@...itsu.com>,
        linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCHv2 3/5] kernel/irq: make irq_{enter,exit}() in
 handle_domain_irq() arch optional

On Fri, Sep 24, 2021 at 09:28:35PM +0800, Pingfan Liu wrote:
> handle_domain_irq() contains two major parts:
>   -1. irq_enter()/irq_exit(), which serves as hooks for rcu and trace etc.
>   -2. irq mapping and dispatching
> 
> After the introduction of irqentry_enter()/irqentry_exit() and arch
> specific counterpart (e.g. arm64), roughly speaking, rcu_irq_enter() has
> already been called.  Hence here comes requirement to move
> irq_enter/irq_exit out of handle_domain_irq(). And arches should handle
> about irq_enter_rcu()/irq_exit_rcu() by themself.
> 
> Since there is still arches, which does not adopt irqentry_enter(), let
> irq_enter()/irq_exit() arch optional in handle_domain_irq().

The patch below looks good to me, but the commit message is a little
hard to follow. How about:

  When an IRQ is taken, some accounting needs to be performed to enter
  and exit IRQ context around the IRQ handler. Historically arch code
  would leave this to the irqchip or core IRQ code, but these days we
  want this to happen in exception entry code, and architectures such as
  arm64 do this.

  Currently handle_domain_irq() performs this entry/exit accounting, and
  if used on an architecture where the entry code also does this, the
  entry/exit accounting will be performed twice per IRQ. This is
  problematic as core RCU code such as rcu_is_cpu_rrupt_from_idle()
  depends on this happening once per IRQ, and will not detect quescent
  periods correctly, leading to stall warnings.

  As irqchip drivers which use handle_domain_irq() need to work on
  architectures with or without their own entry/exit accounting, this
  patch makes handle_domain_irq() conditionally perform the entry
  accounting depending on a new HAVE_ARCH_IRQENTRY Kconfig symbol that
  architectures can select if they perform this entry accounting
  themselves.

  For architectures which do not select the symbol. there should be no
  functional change as a result of this patch.

With that commit message:

  Reviewed-by: Mark Rutland <mark.rutland@....com>

Mark.

> Signed-off-by: Pingfan Liu <kernelfans@...il.com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: Catalin Marinas <catalin.marinas@....com>
> Cc: Will Deacon <will@...nel.org>
> Cc: Mark Rutland <mark.rutland@....com>
> Cc: Marc Zyngier <maz@...nel.org>
> Cc: Joey Gouly <joey.gouly@....com>
> Cc: Sami Tolvanen <samitolvanen@...gle.com>
> Cc: Julien Thierry <julien.thierry@....com>
> Cc: Yuichi Ito <ito-yuichi@...itsu.com>
> Cc: linux-arm-kernel@...ts.infradead.org
> To: linux-kernel@...r.kernel.org
> ---
>  kernel/irq/Kconfig   | 3 +++
>  kernel/irq/irqdesc.c | 4 ++++
>  2 files changed, 7 insertions(+)
> 
> diff --git a/kernel/irq/Kconfig b/kernel/irq/Kconfig
> index fbc54c2a7f23..defa1db2d664 100644
> --- a/kernel/irq/Kconfig
> +++ b/kernel/irq/Kconfig
> @@ -100,6 +100,9 @@ config IRQ_MSI_IOMMU
>  config HANDLE_DOMAIN_IRQ
>  	bool
>  
> +config HAVE_ARCH_IRQENTRY
> +	bool
> +
>  config IRQ_TIMINGS
>  	bool
>  
> diff --git a/kernel/irq/irqdesc.c b/kernel/irq/irqdesc.c
> index 4e3c29bb603c..fd5dd9d278b5 100644
> --- a/kernel/irq/irqdesc.c
> +++ b/kernel/irq/irqdesc.c
> @@ -693,7 +693,9 @@ int handle_domain_irq(struct irq_domain *domain,
>  	struct irq_desc *desc;
>  	int ret = 0;
>  
> +#ifndef CONFIG_HAVE_ARCH_IRQENTRY
>  	irq_enter();
> +#endif
>  
>  	/* The irqdomain code provides boundary checks */
>  	desc = irq_resolve_mapping(domain, hwirq);
> @@ -702,7 +704,9 @@ int handle_domain_irq(struct irq_domain *domain,
>  	else
>  		ret = -EINVAL;
>  
> +#ifndef CONFIG_HAVE_ARCH_IRQENTRY
>  	irq_exit();
> +#endif
>  	set_irq_regs(old_regs);
>  	return ret;
>  }
> -- 
> 2.31.1
> 

Powered by blists - more mailing lists