lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 5 Oct 2021 12:12:31 +0800
From:   Chen Yu <yu.c.chen@...el.com>
To:     "Rafael J. Wysocki" <rafael@...nel.org>
Cc:     Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        ACPI Devel Maling List <linux-acpi@...r.kernel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        Len Brown <len.brown@...el.com>,
        Dan Williams <dan.j.williams@...el.com>,
        Andy Shevchenko <andriy.shevchenko@...el.com>,
        Aubrey Li <aubrey.li@...el.com>,
        Ashok Raj <ashok.raj@...el.com>,
        Mike Rapoport <rppt@...nel.org>,
        Ard Biesheuvel <ardb@...nel.org>,
        Jonathan Corbet <corbet@....net>,
        Hans de Goede <hdegoede@...hat.com>,
        Ben Widawsky <ben.widawsky@...el.com>,
        "open list:DOCUMENTATION" <linux-doc@...r.kernel.org>
Subject: Re: [PATCH v3 3/5] drivers/acpi: Introduce Platform Firmware Runtime
 Update device driver

On Mon, Sep 27, 2021 at 07:40:39PM +0200, Rafael J. Wysocki wrote:
> On Wed, Sep 22, 2021 at 7:28 PM Greg Kroah-Hartman
> <gregkh@...uxfoundation.org> wrote:
> >
> > On Thu, Sep 23, 2021 at 12:33:21AM +0800, Chen Yu wrote:
> > > On Wed, Sep 22, 2021 at 11:10:02AM +0200, Greg Kroah-Hartman wrote:
> > > > On Wed, Sep 22, 2021 at 05:04:42PM +0800, Chen Yu wrote:
> > > > > Hi Greg,
> > > > > On Tue, Sep 21, 2021 at 05:59:05PM +0200, Greg Kroah-Hartman wrote:
> > > > > > On Fri, Sep 17, 2021 at 12:02:18AM +0800, Chen Yu wrote:
> > > > > > > Introduce the pfru_update driver which can be used for Platform Firmware
> > > > > > > Runtime code injection and driver update. The user is expected to provide
> > > > > > > the update firmware in the form of capsule file, and pass it to the driver
> > > > > > > via ioctl. Then the driver would hand this capsule file to the Platform
> > > > > > > Firmware Runtime Update via the ACPI device _DSM method. At last the low
> > > > > > > level Management Mode would do the firmware update.
> > > > > > >
> > > > > > > Signed-off-by: Chen Yu <yu.c.chen@...el.com>
[snip]
> > > > > > > +static struct miscdevice pfru_misc_dev = {
> > > > > > > +     .minor = MISC_DYNAMIC_MINOR,
> > > > > > > +     .name = "pfru_update",
> > > > > > > +     .nodename = "pfru/update",
> > > > > >
> > > > > > Why is this in a subdirectory?  What requires this?  Why not just
> > > > > > "pfru"?
> > > > > >
> > > > > The pfru directory might be reused for pfru_telemetry device, whose driver
> > > > > is in 4/5 patch, I'll Cc you with the whole patch set in next version.
> > > >
> > > > "might be" is not a valid reason.  Why does this simple driver deserve a
> > > > whole /dev/ subdirectory?
> > > >
> > > There are pfru_update and pfru_telemetry in the patch, and there is plan to
> > > add a pfru_prm device in the future, which stands for "Platform Runtime Mechanism".
> > > I'll move them to /dev/ in next version.
> >
> > That is a very generic name for a very platform specific and arch
> > specific interface.  As this is an ACPI interface, why not use that name
> > prefix?
> 
> It is not supposed to be either arch-specific or platform-specific.
> The spec is hosted by the UEFI Forum and it is fairly generic IIUC.
> In principle, it could be used to update any kind of platform firmware
> possible to update without system restart.
> 
> That said, the I/F to the platform firmware is based on ACPI methods,
> so "acpi_" would be a reasonable prefix choice.
Ok, will change it in next version.

Thanks,
Chenyu

Powered by blists - more mailing lists