[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20211026092504.27071-5-mark.rutland@arm.com>
Date: Tue, 26 Oct 2021 10:24:51 +0100
From: Mark Rutland <mark.rutland@....com>
To: linux-kernel@...r.kernel.org
Cc: aou@...s.berkeley.edu, catalin.marinas@....com,
deanbo422@...il.com, green.hu@...il.com, guoren@...nel.org,
jonas@...thpole.se, kernelfans@...il.com,
linux-arm-kernel@...ts.infradead.org, linux@...linux.org.uk,
mark.rutland@....com, maz@...nel.org, nickhu@...estech.com,
palmer@...belt.com, paul.walmsley@...ive.com, shorne@...il.com,
stefan.kristiansson@...nalahti.fi, tglx@...utronix.de,
tsbogend@...ha.franken.de, vgupta@...nel.org,
vladimir.murzin@....com, will@...nel.org
Subject: [PATCH v2 04/17] irq: mips: simplify do_domain_IRQ()
There's no need fpr arch/mips's do_domain_IRQ() to open-code the NULL
check performed by handle_irq_desc(), nor the resolution of the desc
performed by generic_handle_domain_irq().
Use generic_handle_domain_irq() directly, as this is functioanlly
equivalent and clearer.
There should be no functional change as a result of this patch.
Signed-off-by: Mark Rutland <mark.rutland@....com>
Reviewed-by: Marc Zyngier <maz@...nel.org>
Acked-by: Thomas Bogendoerfer <tsbogend@...ha.franken.de>
Cc: Thomas Gleixner <tglx@...utronix.de>
---
arch/mips/kernel/irq.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/arch/mips/kernel/irq.c b/arch/mips/kernel/irq.c
index d20e002b3246..1fee96ef8059 100644
--- a/arch/mips/kernel/irq.c
+++ b/arch/mips/kernel/irq.c
@@ -115,11 +115,7 @@ void __irq_entry do_domain_IRQ(struct irq_domain *domain, unsigned int hwirq)
irq_enter();
check_stack_overflow();
-
- desc = irq_resolve_mapping(domain, hwirq);
- if (likely(desc))
- handle_irq_desc(desc);
-
+ generic_handle_domain_irq(domain, hwirq);
irq_exit();
}
#endif
--
2.11.0
Powered by blists - more mailing lists