[<prev] [next>] [day] [month] [year] [list]
Message-ID: <163524336834.626.3133187281059908061.tip-bot2@tip-bot2>
Date: Tue, 26 Oct 2021 10:16:08 -0000
From: "irqchip-bot for Mark Rutland" <tip-bot2@...utronix.de>
To: linux-kernel@...r.kernel.org
Cc: Mark Rutland <mark.rutland@....com>, Marc Zyngier <maz@...nel.org>,
Thomas Bogendoerfer <tsbogend@...ha.franken.de>,
Thomas Gleixner <tglx@...utronix.de>
Subject: [irqchip: irq/irqchip-next] irq: mips: simplify do_domain_IRQ()
The following commit has been merged into the irq/irqchip-next branch of irqchip:
Commit-ID: 4cb6f4df976b288aa02bbb658d38e73d34d8231f
Gitweb: https://git.kernel.org/pub/scm/linux/kernel/git/maz/arm-platforms/4cb6f4df976b288aa02bbb658d38e73d34d8231f
Author: Mark Rutland <mark.rutland@....com>
AuthorDate: Wed, 20 Oct 2021 18:20:32 +01:00
Committer: Mark Rutland <mark.rutland@....com>
CommitterDate: Mon, 25 Oct 2021 10:05:08 +01:00
irq: mips: simplify do_domain_IRQ()
There's no need fpr arch/mips's do_domain_IRQ() to open-code the NULL
check performed by handle_irq_desc(), nor the resolution of the desc
performed by generic_handle_domain_irq().
Use generic_handle_domain_irq() directly, as this is functioanlly
equivalent and clearer.
There should be no functional change as a result of this patch.
Signed-off-by: Mark Rutland <mark.rutland@....com>
Reviewed-by: Marc Zyngier <maz@...nel.org>
Acked-by: Thomas Bogendoerfer <tsbogend@...ha.franken.de>
Cc: Thomas Gleixner <tglx@...utronix.de>
---
arch/mips/kernel/irq.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/arch/mips/kernel/irq.c b/arch/mips/kernel/irq.c
index d20e002..1fee96e 100644
--- a/arch/mips/kernel/irq.c
+++ b/arch/mips/kernel/irq.c
@@ -115,11 +115,7 @@ void __irq_entry do_domain_IRQ(struct irq_domain *domain, unsigned int hwirq)
irq_enter();
check_stack_overflow();
-
- desc = irq_resolve_mapping(domain, hwirq);
- if (likely(desc))
- handle_irq_desc(desc);
-
+ generic_handle_domain_irq(domain, hwirq);
irq_exit();
}
#endif
Powered by blists - more mailing lists