[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20211028010134.7681-1-yang.guang5@zte.com.cn>
Date: Thu, 28 Oct 2021 01:01:34 +0000
From: Yang Guang <cgel.zte@...il.com>
To: Thomas Winischhofer <thomas@...ischhofer.net>
Cc: Yang Guang <yang.guang5@....com.cn>,
Zeal Robot <zealci@....com.cn>,
dri-devel@...ts.freedesktop.org, linux-fbdev@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH] video: use swap() to make code cleaner
Using swap() make it more readable.
Reported-by: Zeal Robot <zealci@....com.cn>
Signed-off-by: Yang Guang <yang.guang5@....com.cn>
---
drivers/video/fbdev/sis/sis_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/video/fbdev/sis/sis_main.c b/drivers/video/fbdev/sis/sis_main.c
index 266a5582f94d..742f62986b80 100644
--- a/drivers/video/fbdev/sis/sis_main.c
+++ b/drivers/video/fbdev/sis/sis_main.c
@@ -213,7 +213,7 @@ static void sisfb_search_mode(char *name, bool quiet)
/* This does some fuzzy mode naming detection */
if(sscanf(strbuf1, "%u %u %u %u", &xres, &yres, &depth, &rate) == 4) {
if((rate <= 32) || (depth > 32)) {
- j = rate; rate = depth; depth = j;
+ swap(rate, depth);
}
sprintf(strbuf, "%ux%ux%u", xres, yres, depth);
nameptr = strbuf;
--
2.30.2
Powered by blists - more mailing lists