lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 31 Oct 2021 19:49:21 +0200
From:   Jarkko Sakkinen <>
To:     Dave Hansen <>,
        Dave Hansen <>,
        Thomas Gleixner <>,
        Ingo Molnar <>, Borislav Petkov <>,, "H. Peter Anvin" <>,
        Greg Kroah-Hartman <>,
        "Rafael J. Wysocki" <>
Subject: Re: [PATCH v9 2/2] x86/sgx: Add an attribute for the amount of SGX
 memory in a NUMA node

On Fri, 2021-10-29 at 10:00 -0700, Dave Hansen wrote:
> On 10/29/21 5:18 AM, Jarkko Sakkinen wrote:
> > +What:          /sys/devices/system/node/nodeX/sgx/size
> > +Date:          October 2021
> > +Contact:       Jarkko Sakkinen <>
> I don't think we should do something *entirely* SGX-specific here.  The
> only question to me is whether any non-SGX users want something like
> this and who they are.
> Here are some ideas I like more than an "sgx/" directory:
>         /sys/devices/system/node/nodeX/arch/sgx_size
>         /sys/devices/system/node/nodeX/x86/sgx_size
>         /sys/devices/system/node/nodeX/coco/sgx_size

Sure, I can rename the attribute group as "x86".

> There's somebody else *today* who is trying to do something in the same
> general area: per-node platform-specific memory encryption capabilities:
> >

Martin's is adding a new attribute as part of pre-existing attribute group for
node device, where as my patch is adding a completely new named attribute

> Also, could we please think through how this will look if we add more
> attributes?  I can imagine wanting both:
>         * total SGX memory available
>         * total SGX memory present
> But those would be quite hard to differentiate if we have just an
> "sgx_size".
> Wouldn't it be much nicer to name them things like:
>         sgx_present_bytes
>         sgx_available_bytes
> ?
> In other words, can we please try to think just a bit into the future on
> this one?  What other SGX things will we want to export like this?
> Outside of SGX, who else wants stuff _like_ this?

I don't mind renaming the attribute but maybe it should sgx_total_bytes, just
because in some other sysfs attributes that keyword is used to refer all of the


Powered by blists - more mailing lists