lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <bc976b72692512f33ae90183f588af38a06a2aa1.camel@perches.com>
Date:   Sun, 31 Oct 2021 12:17:02 -0700
From:   Joe Perches <joe@...ches.com>
To:     Pavel Skripkin <paskripkin@...il.com>,
        Saurav Girepunje <saurav.girepunje@...il.com>,
        Larry.Finger@...inger.net, phil@...lpotter.co.uk,
        gregkh@...uxfoundation.org, straube.linux@...il.com,
        martin@...ser.cx, linux-staging@...ts.linux.dev,
        linux-kernel@...r.kernel.org
Cc:     saurav.girepunje@...mail.com
Subject: Re: [PATCH] staging: r8188eu: os_dep: remove the goto statement

On Sun, 2021-10-31 at 21:43 +0300, Pavel Skripkin wrote:
> On 10/31/21 21:10, Saurav Girepunje wrote:
> > Remove the goto statement from rtw_init_drv_sw(). In this function goto
> > can be replace by return statement. As on goto label exit, function
> > only return it is not performing any cleanup. Avoiding goto will
> > improve the function readability.
[]
> > diff --git a/drivers/staging/r8188eu/os_dep/os_intfs.c b/drivers/staging/r8188eu/os_dep/os_intfs.c
[]
> > @@ -480,48 +480,34 @@ u8 rtw_init_drv_sw(struct adapter *padapter)
> >   {
> >   	u8	ret8 = _SUCCESS;
> 
> Btw, this variable can be removed completely then. It's used only for:
> 
> ret8 = rtw_init_default_value(padapter);
> 
> with your patch applied, but rtw_init_default_value() always returns 
> _SUCCESS.
> 
> > -exit:
> >  	return ret8;
> >  }
> 
> And just `return _SUCCESS;` here.

And maybe one day s/_SUCCESS/true/ and s/_FAIL/false/
with appropriate conversions to bool


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ