[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75VedwDcBoz=dOGf_-7aOHC1mdvT8+hyvyK+hbK-5soJoYw@mail.gmail.com>
Date: Thu, 4 Nov 2021 12:33:19 +0200
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: davidcomponentone@...il.com
Cc: Jonathan Cameron <jic23@...nel.org>,
Lars-Peter Clausen <lars@...afoo.de>,
linux-iio <linux-iio@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Yang Guang <yang.guang5@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] tools: iio: use swap() to make code cleaner
On Thu, Nov 4, 2021 at 8:21 AM <davidcomponentone@...il.com> wrote:
>
> From: Yang Guang <yang.guang5@....com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
Same as per other patches. Don't be a dump addon to the robot, think
about the code a little bit more.
> void bsort_channel_array_by_index(struct iio_channel_info *ci_array, int cnt)
> {
> - struct iio_channel_info temp;
> int x, y;
>
> for (x = 0; x < cnt; x++)
> for (y = 0; y < (cnt - 1); y++)
> if (ci_array[y].index > ci_array[y + 1].index) {
> - temp = ci_array[y + 1];
> - ci_array[y + 1] = ci_array[y];
> - ci_array[y] = temp;
> + swap(ci_array[y + 1], ci_array[y]);
> }
Name of the function suggests it's a sort, we have the sort_r() API,
use it instead.
> }
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists