[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20211104110900.GB3164@kadam>
Date: Thu, 4 Nov 2021 14:09:00 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: davidcomponentone@...il.com
Cc: zbr@...emap.net, gregkh@...uxfoundation.org,
ivan.zaentsev@...enboard.ru, yangyingliang@...wei.com,
unixbhaskar@...il.com, yang.guang5@....com.cn,
linux-kernel@...r.kernel.org, Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] w1: w1_therm: use swap() to make code cleaner
On Thu, Nov 04, 2021 at 09:11:23AM +0800, davidcomponentone@...il.com wrote:
> From: Yang Guang <yang.guang5@....com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
>
> Reported-by: Zeal Robot <zealci@....com.cn>
> Signed-off-by: Yang Guang <yang.guang5@....com.cn>
> ---
I'm confused by the signed-off-by list. Are you Yang Guang and David is
your "English name"? If so then this is fine, but if you are different
people then everyone who handles the patch needs to add their own
signed-off-by.
> @@ -1837,7 +1837,7 @@ static ssize_t alarms_store(struct device *device,
>
> /* Reorder if required th and tl */
> if (tl > th) {
> - tt = tl; tl = th; th = tt;
> + swap(tl, th);
> }
Remove the curly {} braces as well because they are no longer required.
regards,
dan carpenter
Powered by blists - more mailing lists