[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20211104001847.694982-1-yang.guang5@zte.com.cn>
Date: Thu, 4 Nov 2021 08:18:46 +0800
From: davidcomponentone@...il.com
To: peterz@...radead.org
Cc: davidcomponentone@...il.com, mingo@...hat.com, will@...nel.org,
longman@...hat.com, boqun.feng@...il.com,
linux-kernel@...r.kernel.org, Yang Guang <yang.guang5@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: [PATCH] locking/ww-mutex: use swap() to make code cleaner
From: Yang Guang <yang.guang5@....com.cn>
Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.
Signed-off-by: Yang Guang <yang.guang5@....com.cn>
Reported-by: Zeal Robot <zealci@....com.cn>
---
kernel/locking/test-ww_mutex.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/kernel/locking/test-ww_mutex.c b/kernel/locking/test-ww_mutex.c
index 353004155d65..daad819fcd16 100644
--- a/kernel/locking/test-ww_mutex.c
+++ b/kernel/locking/test-ww_mutex.c
@@ -389,7 +389,7 @@ struct stress {
static int *get_random_order(int count)
{
int *order;
- int n, r, tmp;
+ int n, r;
order = kmalloc_array(count, sizeof(*order), GFP_KERNEL);
if (!order)
@@ -401,9 +401,7 @@ static int *get_random_order(int count)
for (n = count - 1; n > 1; n--) {
r = get_random_int() % (n + 1);
if (r != n) {
- tmp = order[n];
- order[n] = order[r];
- order[r] = tmp;
+ swap(order[n], order[r]);
}
}
--
2.30.2
Powered by blists - more mailing lists