[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20211104011616.1028001-1-yang.guang5@zte.com.cn>
Date: Thu, 4 Nov 2021 09:16:16 +0800
From: davidcomponentone@...il.com
To: urezki@...il.com
Cc: davidcomponentone@...il.com, akpm@...ux-foundation.org,
yang.guang5@....com.cn, linux-kernel@...r.kernel.org,
Zeal Robot <zealci@....com.cn>
Subject: [PATCH] lib/test_vmalloc.c: use swap() to make code cleaner
From: Yang Guang <yang.guang5@....com.cn>
Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.
Reported-by: Zeal Robot <zealci@....com.cn>
Signed-off-by: Yang Guang <yang.guang5@....com.cn>
---
lib/test_vmalloc.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/lib/test_vmalloc.c b/lib/test_vmalloc.c
index e14993bc84d2..cf41fd6df42a 100644
--- a/lib/test_vmalloc.c
+++ b/lib/test_vmalloc.c
@@ -393,7 +393,7 @@ static struct test_driver {
static void shuffle_array(int *arr, int n)
{
unsigned int rnd;
- int i, j, x;
+ int i, j;
for (i = n - 1; i > 0; i--) {
get_random_bytes(&rnd, sizeof(rnd));
@@ -402,9 +402,7 @@ static void shuffle_array(int *arr, int n)
j = rnd % i;
/* Swap indexes. */
- x = arr[i];
- arr[i] = arr[j];
- arr[j] = x;
+ swap(arr[i], arr[j]);
}
}
--
2.30.2
Powered by blists - more mailing lists