[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <YYTVEPVNITE8EEHk@kroah.com>
Date: Fri, 5 Nov 2021 07:54:08 +0100
From: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To: Cai Huoqing <caihuoqing@...du.com>
Cc: "Rafael J. Wysocki" <rafael@...nel.org>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] driver core: platform: Make use of the helper function
dev_err_probe()
On Fri, Nov 05, 2021 at 11:09:59AM +0800, Cai Huoqing wrote:
> When possible using dev_err_probe() helps to properly deal with the
> PROBE_DEFER error, the benefit is that DEFER issue will be logged
> in the devices_deferred debugfs file.
> BTW rename 'dev' to 'pdev'.
"BTW"???
> Signed-off-by: Cai Huoqing <caihuoqing@...du.com>
> ---
> drivers/base/platform.c | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/base/platform.c b/drivers/base/platform.c
> index 598acf93a360..5befd3258677 100644
> --- a/drivers/base/platform.c
> +++ b/drivers/base/platform.c
> @@ -253,13 +253,14 @@ EXPORT_SYMBOL_GPL(platform_get_irq_optional);
> *
> * Return: non-zero IRQ number on success, negative error number on failure.
> */
> -int platform_get_irq(struct platform_device *dev, unsigned int num)
> +int platform_get_irq(struct platform_device *pdev, unsigned int num)
Why change the variable name? It has nothing to do with this change,
please do not do that.
thanks,
greg k-h
Powered by blists - more mailing lists