[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20211110030715.21681-1-hanyihao@vivo.com>
Date: Tue, 9 Nov 2021 19:07:12 -0800
From: Yihao Han <hanyihao@...o.com>
To: Vineet Gupta <vgupta@...nel.org>, Yihao Han <hanyihao@...o.com>,
Jinchao Wang <wjc@...rlc.com>,
"dean.yang_cp" <yangdianqing@...ong.com>,
linux-snps-arc@...ts.infradead.org, linux-kernel@...r.kernel.org
Cc: kernel@...o.com
Subject: [PATCH] arc: use swap() to make code cleaner
Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.
Signed-off-by: Yihao Han <hanyihao@...o.com>
---
arch/arc/kernel/unwind.c | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)
diff --git a/arch/arc/kernel/unwind.c b/arch/arc/kernel/unwind.c
index 9e28058cdba8..200270a94558 100644
--- a/arch/arc/kernel/unwind.c
+++ b/arch/arc/kernel/unwind.c
@@ -245,14 +245,9 @@ static void swap_eh_frame_hdr_table_entries(void *p1, void *p2, int size)
{
struct eh_frame_hdr_table_entry *e1 = p1;
struct eh_frame_hdr_table_entry *e2 = p2;
- unsigned long v;
-
- v = e1->start;
- e1->start = e2->start;
- e2->start = v;
- v = e1->fde;
- e1->fde = e2->fde;
- e2->fde = v;
+
+ swap(e1->start, e2->start);
+ swap(e1->fde, e2->fde);
}
static void init_unwind_hdr(struct unwind_table *table,
--
2.17.1
Powered by blists - more mailing lists