[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-id: <163709852340.13692.16362531894844686350@noble.neil.brown.name>
Date: Wed, 17 Nov 2021 08:35:23 +1100
From: "NeilBrown" <neilb@...e.de>
To: "Christoph Hellwig" <hch@...radead.org>
Cc: "Trond Myklebust" <trond.myklebust@...merspace.com>,
"Anna Schumaker" <anna.schumaker@...app.com>,
"Chuck Lever" <chuck.lever@...cle.com>,
"Andrew Morton" <akpm@...ux-foundation.org>,
"Mel Gorman" <mgorman@...e.de>, linux-nfs@...r.kernel.org,
linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 03/13] MM: reclaim mustn't enter FS for swap-over-NFS
On Tue, 16 Nov 2021, Christoph Hellwig wrote:
> On Tue, Nov 16, 2021 at 01:44:04PM +1100, NeilBrown wrote:
> > + /* ->flags can be updated non-atomicially (scan_swap_map_slots),
> > + * but that will never affect SWP_FS_OPS, so the data_race
> > + * is safe.
> > + */
> > may_enter_fs = (sc->gfp_mask & __GFP_FS) ||
> > + (PageSwapCache(page) &&
> > + !data_race(page_swap_info(page)->flags & SWP_FS_OPS) &&
> > + (sc->gfp_mask & __GFP_IO));
>
> You might want to move the comment and SWP_FS_OPS into a little
> inline helper. That makes it a lot more readable and also avoids the
> overly long line in the second hunk.
Yes, that's a good idea. Something like this....
Thanks,
NeilBrown
>From a85d09cc3d671c45e32d782454afeeaaaece96c7 Mon Sep 17 00:00:00 2001
From: NeilBrown <neilb@...e.de>
Date: Fri, 29 Oct 2021 13:35:56 +1100
Subject: [PATCH] MM: reclaim mustn't enter FS for swap-over-NFS
If swap-out is using filesystem operations (SWP_FS_OPS), then it is not
safe to enter the FS for reclaim.
So only down-grade the requirement for swap pages to __GFP_IO after
checking that SWP_FS_OPS are not being used.
Signed-off-by: NeilBrown <neilb@...e.de>
---
mm/vmscan.c | 21 ++++++++++++++++++---
1 file changed, 18 insertions(+), 3 deletions(-)
diff --git a/mm/vmscan.c b/mm/vmscan.c
index fb9584641ac7..e672fcc14bac 100644
--- a/mm/vmscan.c
+++ b/mm/vmscan.c
@@ -1464,6 +1464,21 @@ static unsigned int demote_page_list(struct list_head *demote_pages,
return nr_succeeded;
}
+static bool test_may_enter_fs(struct page *page, gfp_t gfp_mask)
+{
+ if (gfp_mask & __GFP_FS)
+ return true;
+ if (!PageSwapCache(page) || !(gfp_mask & __GFP_IO))
+ return false;
+ /* We can "enter_fs" for swap-cache with only __GFP_IO
+ * providing this isn't SWP_FS_OPS.
+ * ->flags can be updated non-atomicially (scan_swap_map_slots),
+ * but that will never affect SWP_FS_OPS, so the data_race
+ * is safe.
+ */
+ return !data_race(page_swap_info(page)->flags & SWP_FS_OPS);
+}
+
/*
* shrink_page_list() returns the number of reclaimed pages
*/
@@ -1513,8 +1528,7 @@ static unsigned int shrink_page_list(struct list_head *page_list,
if (!sc->may_unmap && page_mapped(page))
goto keep_locked;
- may_enter_fs = (sc->gfp_mask & __GFP_FS) ||
- (PageSwapCache(page) && (sc->gfp_mask & __GFP_IO));
+ may_enter_fs = test_may_enter_fs(page, sc->gfp_mask);
/*
* The number of dirty pages determines if a node is marked
@@ -1682,7 +1696,8 @@ static unsigned int shrink_page_list(struct list_head *page_list,
goto activate_locked_split;
}
- may_enter_fs = true;
+ may_enter_fs = test_may_enter_fs(page,
+ sc->gfp_mask);
/* Adding to swap updated mapping */
mapping = page_mapping(page);
--
2.33.1
Powered by blists - more mailing lists