lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 18 Nov 2021 11:43:02 +0100
From:   John Paul Adrian Glaubitz <glaubitz@...sik.fu-berlin.de>
To:     cgel.zte@...il.com, akpm@...ux-foundation.org
Cc:     slyfox@...too.org, linux-ia64@...r.kernel.org,
        linux-kernel@...r.kernel.org, Yao Jing <yao.jing2@....com.cn>,
        Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] ia64: module: use swap() to make code cleaner

Hi!

On 11/18/21 07:20, cgel.zte@...il.com wrote:
> From: Yao Jing <yao.jing2@....com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
> 
> Reported-by: Zeal Robot <zealci@....com.cn>
> Signed-off-by: Yao Jing <yao.jing2@....com.cn>
> ---
>  arch/ia64/kernel/module.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/arch/ia64/kernel/module.c b/arch/ia64/kernel/module.c
> index 2cba53c1da82..360f36b0eb3f 100644
> --- a/arch/ia64/kernel/module.c
> +++ b/arch/ia64/kernel/module.c
> @@ -848,7 +848,7 @@ register_unwind_table (struct module *mod)
>  {
>  	struct unw_table_entry *start = (void *) mod->arch.unwind->sh_addr;
>  	struct unw_table_entry *end = start + mod->arch.unwind->sh_size / sizeof (*start);
> -	struct unw_table_entry tmp, *e1, *e2, *core, *init;
> +	struct unw_table_entry *e1, *e2, *core, *init;
>  	unsigned long num_init = 0, num_core = 0;
>  
>  	/* First, count how many init and core unwind-table entries there are.  */
> @@ -865,9 +865,7 @@ register_unwind_table (struct module *mod)
>  	for (e1 = start; e1 < end; ++e1) {
>  		for (e2 = e1 + 1; e2 < end; ++e2) {
>  			if (e2->start_offset < e1->start_offset) {
> -				tmp = *e1;
> -				*e1 = *e2;
> -				*e2 = tmp;
> +				swap(*e1, *e2);
>  			}
>  		}
>  	}

I will test this patch later this week.

Adrian

-- 
 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@...ian.org
`. `'   Freie Universitaet Berlin - glaubitz@...sik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ