[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAHk-=wjUajzA9rDmxGzH209bQ_VGz3RfOgb85BYkBDSEM1HpPg@mail.gmail.com>
Date: Mon, 22 Nov 2021 12:23:42 -0800
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Guenter Roeck <linux@...ck-us.net>
Cc: Anton Altaparmakov <anton@...era.com>,
linux-ntfs-dev@...ts.sourceforge.net,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Michael Ellerman <mpe@...erman.id.au>,
Stephen Rothwell <sfr@...b.auug.org.au>
Subject: Re: [PATCH] fs: ntfs: Mark NTFS_RW as BROKEN for PPC
On Mon, Nov 22, 2021 at 12:13 PM Guenter Roeck <linux@...ck-us.net> wrote:
>
> The Kconfig language does not support "depends on XXX if YYY",
> so this is the next best choice.
Ugh. This is hard to read, and it will get much worse if we then end
up making the conditional more complicated if we actually want to
introduce some page size logic..
> config NTFS_RW
> bool "NTFS write support"
> + depends on BROKEN || !PPC
> depends on NTFS_FS
> help
> This enables the partial, but safe, write support in the NTFS driver.
How about we do a
config DISABLE_NTFS_RW
bool
default y if PPC
and then in NTFS_RW we just do
depends on !DISABLE_NTFS_RW
which at least makes each case easy, and makes it much clearer if we
extend that DISABLE_NTFS_RW condition later.
Linus
Powered by blists - more mailing lists