[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <7bdc7ee3dcc09a109cfaf9fb8662fb49ca0bec2c.1637884349.git.maciej.szmigiero@oracle.com>
Date: Fri, 26 Nov 2021 01:31:08 +0100
From: "Maciej S. Szmigiero" <mail@...iej.szmigiero.name>
To: Paolo Bonzini <pbonzini@...hat.com>
Cc: Sean Christopherson <seanjc@...gle.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Wanpeng Li <wanpengli@...cent.com>,
Jim Mattson <jmattson@...gle.com>,
Joerg Roedel <joro@...tes.org>,
Igor Mammedov <imammedo@...hat.com>, kvm@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH 2/3] KVM: Use atomic_long_cmpxchg() instead of an open-coded variant
From: "Maciej S. Szmigiero" <maciej.szmigiero@...cle.com>
Open-coding a cmpxchg()-like operation is significantly less readable than
a direct call.
Also, the open-coded version compiles to multiple instructions with
a branch on x86, instead of just a single instruction.
Since technically the open-coded variant didn't guarantee actual atomicity
add a comment there, too, that this property isn't strictly required in
this case.
Signed-off-by: Maciej S. Szmigiero <maciej.szmigiero@...cle.com>
---
virt/kvm/kvm_main.c | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c
index d4399db06d49..367c1cba26d2 100644
--- a/virt/kvm/kvm_main.c
+++ b/virt/kvm/kvm_main.c
@@ -1378,8 +1378,12 @@ static void kvm_replace_memslot(struct kvm *kvm,
hash_del(&old->id_node[idx]);
interval_tree_remove(&old->hva_node[idx], &slots->hva_tree);
- if ((long)old == atomic_long_read(&slots->last_used_slot))
- atomic_long_set(&slots->last_used_slot, (long)new);
+ /*
+ * The atomicity isn't strictly required here since we are
+ * operating on an inactive memslots set anyway.
+ */
+ atomic_long_cmpxchg(&slots->last_used_slot,
+ (unsigned long)old, (unsigned long)new);
if (!new) {
kvm_erase_gfn_node(slots, old);
Powered by blists - more mailing lists