lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 02 Dec 2021 12:38:05 +0000
From:   Kieran Bingham <kieran.bingham@...asonboard.com>
To:     Christophe JAILLET <christophe.jaillet@...adoo.fr>,
        laurent.pinchart@...asonboard.com, mchehab@...nel.org,
        sakari.ailus@...ux.intel.com
Cc:     linux-media@...r.kernel.org, linux-kernel@...r.kernel.org,
        kernel-janitors@...r.kernel.org,
        Christophe JAILLET <christophe.jaillet@...adoo.fr>
Subject: Re: [PATCH] media: mc: mc-entity.c: Use bitmap_zalloc() when applicable

Quoting Christophe JAILLET (2021-12-01 22:19:40)
> 'ent_enum->bmap' is a bitmap. So use 'bitmap_zalloc()' to simplify
> code, improve the semantic and avoid some open-coded arithmetic in
> allocator arguments.
> 
> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> consistency.
> 
> While at it, remove a useless 'bitmap_zero()'.

Ah, yes kcalloc zeros memory, so it is doing a redundant clear as well.
Changing to bitmap_zalloc looks a lot better though.

Reviewed-by: Kieran Bingham <kieran.bingham+renesas@...asonboard.com>

> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@...adoo.fr>
> ---
>  drivers/media/mc/mc-entity.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/media/mc/mc-entity.c b/drivers/media/mc/mc-entity.c
> index c02340698ad6..b411f9796191 100644
> --- a/drivers/media/mc/mc-entity.c
> +++ b/drivers/media/mc/mc-entity.c
> @@ -48,12 +48,10 @@ __must_check int __media_entity_enum_init(struct media_entity_enum *ent_enum,
>                                           int idx_max)
>  {
>         idx_max = ALIGN(idx_max, BITS_PER_LONG);
> -       ent_enum->bmap = kcalloc(idx_max / BITS_PER_LONG, sizeof(long),
> -                                GFP_KERNEL);
> +       ent_enum->bmap = bitmap_zalloc(idx_max, GFP_KERNEL);
>         if (!ent_enum->bmap)
>                 return -ENOMEM;
>  
> -       bitmap_zero(ent_enum->bmap, idx_max);
>         ent_enum->idx_max = idx_max;
>  
>         return 0;
> @@ -62,7 +60,7 @@ EXPORT_SYMBOL_GPL(__media_entity_enum_init);
>  
>  void media_entity_enum_cleanup(struct media_entity_enum *ent_enum)
>  {
> -       kfree(ent_enum->bmap);
> +       bitmap_free(ent_enum->bmap);
>  }
>  EXPORT_SYMBOL_GPL(media_entity_enum_cleanup);
>  
> -- 
> 2.30.2
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ