[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20211208183711.390454-4-isabbasso@riseup.net>
Date: Wed, 8 Dec 2021 15:37:09 -0300
From: Isabella Basso <isabbasso@...eup.net>
To: geert@...ux-m68k.org, brendanhiggins@...gle.com,
dlatypov@...gle.com, davidgow@...gle.com,
akpm@...ux-foundation.org, skhan@...uxfoundation.org
Cc: ferreiraenzoa@...il.com, augusto.duraes33@...il.com,
linux-kselftest@...r.kernel.org, linux-kernel@...r.kernel.org,
kunit-dev@...glegroups.com, ~lkcamp/patches@...ts.sr.ht,
rodrigosiqueiramelo@...il.com,
Isabella Basso <isabbasso@...eup.net>
Subject: [PATCH RESEND v3 3/5] test_hash.c: split test_hash_init
Split up test_hash_init so that it calls each test more explicitly
insofar it is possible without rewriting the entire file. This aims at
improving readability.
Split tests performed on string_or as they don't interfere with those
performed in hash_or. Also separate pr_info calls about skipped tests as
they're not part of the tests themselves, but only warn about
(un)defined arch-specific hash functions.
Reviewed-by: David Gow <davidgow@...gle.com>
Tested-by: David Gow <davidgow@...gle.com>
Signed-off-by: Isabella Basso <isabbasso@...eup.net>
---
Changes since v1:
- As suggested by David Gow:
1. Rename arch-specific test functions.
2. Remove spare whitespace changes.
lib/test_hash.c | 66 ++++++++++++++++++++++++++++++++++++++++---------
1 file changed, 54 insertions(+), 12 deletions(-)
diff --git a/lib/test_hash.c b/lib/test_hash.c
index 2b4fe4976cc4..032849a48da7 100644
--- a/lib/test_hash.c
+++ b/lib/test_hash.c
@@ -158,11 +158,39 @@ test_int_hash(unsigned long long h64, u32 hash_or[2][33])
#define SIZE 256 /* Run time is cubic in SIZE */
-static int __init
-test_hash_init(void)
+static int __init test_string_or(void)
{
char buf[SIZE+1];
- u32 string_or = 0, hash_or[2][33] = { { 0, } };
+ u32 string_or = 0;
+ int i, j;
+
+ fill_buf(buf, SIZE, 1);
+
+ /* Test every possible non-empty substring in the buffer. */
+ for (j = SIZE; j > 0; --j) {
+ buf[j] = '\0';
+
+ for (i = 0; i <= j; i++) {
+ u32 h0 = full_name_hash(buf+i, buf+i, j-i);
+
+ string_or |= h0;
+ } /* i */
+ } /* j */
+
+ /* The OR of all the hash values should cover all the bits */
+ if (~string_or) {
+ pr_err("OR of all string hash results = %#x != %#x",
+ string_or, -1u);
+ return -EINVAL;
+ }
+
+ return 0;
+}
+
+static int __init test_hash_or(void)
+{
+ char buf[SIZE+1];
+ u32 hash_or[2][33] = { { 0, } };
unsigned tests = 0;
unsigned long long h64 = 0;
int i, j;
@@ -192,7 +220,6 @@ test_hash_init(void)
return -EINVAL;
}
- string_or |= h0;
h64 = h64 << 32 | h0; /* For use with hash_64 */
if (!test_int_hash(h64, hash_or))
return -EINVAL;
@@ -200,12 +227,6 @@ test_hash_init(void)
} /* i */
} /* j */
- /* The OR of all the hash values should cover all the bits */
- if (~string_or) {
- pr_err("OR of all string hash results = %#x != %#x",
- string_or, -1u);
- return -EINVAL;
- }
if (~hash_or[0][0]) {
pr_err("OR of all __hash_32 results = %#x != %#x",
hash_or[0][0], -1u);
@@ -237,6 +258,13 @@ test_hash_init(void)
}
}
+ pr_notice("%u tests passed.", tests);
+
+ return 0;
+}
+
+static void __init notice_skipped_tests(void)
+{
/* Issue notices about skipped tests. */
#ifdef HAVE_ARCH__HASH_32
#if HAVE_ARCH__HASH_32 != 1
@@ -252,10 +280,24 @@ test_hash_init(void)
#else
pr_info("hash_64() has no arch implementation to test.");
#endif
+}
- pr_notice("%u tests passed.", tests);
+static int __init
+test_hash_init(void)
+{
+ int ret;
- return 0;
+ ret = test_string_or();
+ if (ret < 0)
+ return ret;
+
+ ret = test_hash_or();
+ if (ret < 0)
+ return ret;
+
+ notice_skipped_tests();
+
+ return ret;
}
static void __exit test_hash_exit(void)
--
2.34.1
Powered by blists - more mailing lists